WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] BUG: Endless loading .ics Google Calendar (12 posts)

  1. achensee
    Member
    Posted 2 years ago #

    I created public events on a google calendar and addet the ics feed url https://www.google.com/calendar/ical/achensee.tourismus%40gmail.com/public/basic.ics to the settings. i click on "update", but nothing will be imprted - the loading-icon is spinning endless... am i doing someting wrong?

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @achensee
    1. Are you able to add events using Add Event form?
    2. Is it a local or a hosted WP install?
    3. What is the OS on the server?

  3. achensee
    Member
    Posted 2 years ago #

    ad1) yes
    ad2) dedicated webserver
    ad3) linux with apache 1.3.41, PHP Version 5.2.17

  4. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @achensee
    I will run a few tests with your ics feed today and see if there are any bugs in the plugin.

  5. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @achensee
    Just tested the feed with v1.0.7
    It imports successfully on my side.
    Could it be a firewall issue?
    httpd needs to be able to make connections to ports 443 (https) and 80 (http)

  6. baszer
    Member
    Posted 2 years ago #

    what did you do to make it work?

    mine is local and does the same as you descriped

  7. achensee
    Member
    Posted 2 years ago #

    this function still doesn't work with my blog. would it be possible to implement an xml-file-import? if so, then i could download the .ics from google calendar to my pc and then upload it to my blog...

  8. nearlyjen
    Member
    Posted 2 years ago #

    i'm having this problem - suddenly - today, too. my "main" Google calendar .ics is getting an endlessly spinning update icon...but not my other calendars.
    we are also on a local install and i can add an event just fine though the add event form.

    is it a Google problem? I noticed something similar listed in today's "Known Issues" on the calendar site...

  9. nearlyjen
    Member
    Posted 2 years ago #

    hmm. while the icon was still spinning, i opened a new tab and the events were loaded there...

    something new is driving me crazy, though. i deleted all of my events and flushed all of my calendars and started from scratch. my calendar events add up to 389, but i have 390 events listed. how could i have imported 389 events and have 390 events???

  10. dexter10
    Member
    Posted 2 years ago #

    I have a related but slightly different problem:

    My public .ics file will not import as per the other posters here. When I update, the icon spins and then returns nothing. At least it does stop as if it has been updated. I tried the public .ics file from achensee above and the icon spun indefinitely. So it seems like my .ics file is doing something.

    However, the private .ics works fine. Go figure. Updates fine, no problems and it shows properly in the calendar.

    The problem is that my client only wants to show that he is unavailable on the days and not the details of the agenda. I have selected the "show only my status" in the Google Agenda page for the public agenda, but since the plugin is only importing the private agenda this doesn't cut the mustard. The user can see all his personal meetings.

    I have done the test.php as recommended in another post (can't seem to track down that particular post at the moment) and the output was as it should be. But the fact that the private .ics is working while the public file does not is strange to say the least.

    Any other ideas or solutions?

    Thanks in advance.

  11. Yani Iliev
    Member
    Plugin Contributor

    Posted 2 years ago #

    @nearlyjen
    It could be another plugin that is causing the error.

    @dexter10
    If you compare the private and the public ics feeds, could it be that one is using http while the other is using https?

  12. cstarre
    Member
    Posted 2 years ago #

    Does anyone have a problem with the "Month" "Week" "Icons" stacking on the page, instead of being on one row?

    The page looks crammed but has enough room.

    http://www.calvennstarre.com/home/calendar

    Thanks for the input.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic