WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] AI1EC Forcing Header on Event Detail Page (14 posts)

  1. 00coday
    Member
    Posted 2 years ago #

    For some reason the AI1EC is forcing a header on my event detail pages. An example is at
    http://sbe131.org/ai1ec_event/sbe-barbeque/?instance_id=1571

    I poked around the PHP files in the plugin, but nothing jumped out at me as the culprit.

    Thanks in advance for the help

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Richard
    Member
    Posted 1 year ago #

    Hi 00coday,

    I tried to click on your link, but your site is not available.

    Some other users have had conflicts between their WP themes and the ai1ec - this could be what is happening here. In order to be sure, can you temporarily switch WP themes to Twenty Eleven. If this resolves the issue, then it must be a theme conflict. If this is the case, then you could try downloading the latest (1.8 premium) version of the plugin, which has had its javascript completely refactored in order to resolve many of the javascript/theme conflict issues. It is still being tested, but is available for download from http://help.then.ly

    Feedback is vital to continually improving the plugin, so please let us know if this resolves the issue for you.

  3. billsen
    Member
    Posted 1 year ago #

    I am having the same issue on a client's site - you can see it here:

    http://www.cooleyforcongress.com/ai1ec_event/cooley-for-congress-campaign-kickoff/?instance_id=2

    Upgraded to the latest build this morning, but still not resolved (but thanks for the Google map fix!)

    Over all, this is a fantastic plug-in, so I am hopeful that you can resolve this last issue - changing themes is not an option - using "blogolife" theme.

    Thanks!

  4. Yani Iliev
    Member
    Plugin Contributor

    Posted 1 year ago #

    @billsen
    It seems the theme files were not updated.
    1. Disable the plugin (only disable do NOT uninstall it)
    2. FTP to your server
    3. Delete wp-content/themes-ai1ec folder
    4. Go to your dashboard (domain/wp-admin) and activate the plugin
    5. You will be asked to install themes - follow the instructions (it should be a very straightforward process)
    Let me know the result.

  5. billsen
    Member
    Posted 1 year ago #

    I did exactly what you suggested, and still have the same result. When I reactivated it didn't ask to install the themes... And I now see no themes folder in the ftp view...

  6. Yani Iliev
    Member
    Plugin Contributor

    Posted 1 year ago #

    @ billsen
    1. Are you running ai1ec v1.8.3-premium?
    2. Did you refresh the folder in your ftp client?
    3. What WP version are you running?

  7. Yani Iliev
    Member
    Plugin Contributor

    Posted 1 year ago #

    @ billsen
    Nevermind - the plugin does work properly.
    The problem is in the theme. I will tell you how to fix it.
    Can you paste your header.php file from your theme on wordpress.pastebin.com and provide a link to it?

  8. billsen
    Member
    Posted 1 year ago #

    WP 3.4.1
    and ai1ec 1.8.3

  9. billsen
    Member
    Posted 1 year ago #

    Pastebin link to header:

    http://pastebin.com/idmd8GjP

  10. Yani Iliev
    Member
    Plugin Contributor

    Posted 1 year ago #

    Change line 31
    From this:
    <?php wplook_meta_description();?>
    to this:

    <?php if( get_post_type() !== AI1EC_POST_TYPE ) : ?>
    <?php wplook_meta_description();?>
    <?php endif ?>
  11. billsen
    Member
    Posted 1 year ago #

    That did the trick! Thank you! Once the client settles up, I will make a donation.

  12. Yani Iliev
    Member
    Plugin Contributor

    Posted 1 year ago #

    I am glad it worked.

  13. joemastro
    Member
    Posted 1 year ago #

    yani.iliev = awesome...

    Thanks!

  14. joemastro
    Member
    Posted 1 year ago #

    yani.iliev = awesome...

    Thanks!

  15. cynthiakingpei
    Member
    Posted 1 year ago #

    Thank you for this solution:

    Change line 31
    From this:
    <?php wplook_meta_description();?>
    to this:
    <?php if( get_post_type() !== AI1EC_POST_TYPE ) : ?>
    <?php wplook_meta_description();?>
    <?php endif ?>

    Worked perfectly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.