WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] 1.6.3 is seriously broken (27 posts)

  1. 2005wcbs
    Member
    Posted 1 year ago #

    I have installed this update today, it took my entire site down and showed an error. I have had to remove the entire plugin and the theme addition (What is that for?) via ftp and reinstall and older version. This does not work.

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Lidali
    Member
    Posted 1 year ago #

    With my WP version 3.3.2 it is not working at all in Internet Explorer (Firefox and Safari works fine). It just doesn't show any text at all.
    Put back version 1.2.5 which seemed to work for all three browsers.

  3. nearlyjen
    Member
    Posted 1 year ago #

    Same here. Installed the update and my whole site went down. That was fun.

  4. MrDarkHorse
    Member
    Posted 1 year ago #

    My site is still working, but it totally screwed up my menu at the top by injecting general.css into the equation. Not sure what's up with that.

  5. sauril
    Member
    Posted 1 year ago #

    general.css has always been a part of the plugin. What is the specific issue?

  6. 2005wcbs
    Member
    Posted 1 year ago #

    Read the first post. The issue is it don't work, it took my entire site down. It's seriously broken.

  7. sauril
    Member
    Posted 1 year ago #

    My last post was to MrDarKHorse

    2005wcbs, do you still have the error message?

  8. 2005wcbs
    Member
    Posted 1 year ago #

    Okay sauril understood

    Of course I don't still have the error, it took my entire site down leaving only an error message, no WP dashboard, no site. I had to fix that, and quickly. I had to ftp to the server and manually remove the plugin and, annoyingly, all the stuff that now appears outside of the plug in directory. That's not a good thing at all. I then had to find an older version and upload that. I am now using that older version and will not update again if this is what happens.

    I am now looking for a replacement plugin, as this is now so broken it is of no use to me.

  9. denisechapman
    Member
    Posted 1 year ago #

    Definitely a big problem. I just did the update and it caused an error. It does not play nice with the "connections" plug in. Going to find a different calendar.

  10. denisechapman
    Member
    Posted 1 year ago #

    P.S. deactivating it or re-installing old one does not fix the mess. thank goodness I did a backup!

  11. sauril
    Member
    Posted 1 year ago #

    I'm sorry to hear that you guys are having problems - if there are errors, it's useful for us to know what they are so we can fix them.

    denisechapman - there are always going to be conflicts with other plugins - if you can tell us what the error is with the "connections" plugin, we can investigate

  12. meredithmarsh
    Member
    Posted 1 year ago #

    Is there someplace I can download a previous version so that I can get things working in IE?

    One thing I notice is that the events seem to be "there" they just aren't showing (in IE). They appear for a moment when the page loads, but then go away.

    If I open firebug lite, they appear. Seems like a CSS issue.

    Experience it for yourself, at http://www.pypl.org/?page_id=38

  13. 2005wcbs
    Member
    Posted 1 year ago #

    Yes there will sometime be conflicts with other plugins. But in this case the Calendar was working fine. Only when I updated the calendar plugin did it then take down my entire site. They have changed it so radically that it just does not work. It was clearly not tested properly and there seem to be no fix or even an acknowledgement that they have screwed it up completely.

    The ONLY option now is another plug in, any suggestions??

  14. 2005wcbs
    Member
    Posted 1 year ago #

    I should add I need one that has a good 'List View', not just a monthly display.

  15. klartext-ne
    Member
    Posted 1 year ago #

    Good news .. 1.7 is working fine! I also had only trouble with 1.6.2 & 1.6.3 and wend back to 1.5. Today i tried 1.7 and found NO problems. Maybe this would help you too.

  16. 2005wcbs
    Member
    Posted 1 year ago #

    I have just, very foolishly, installed version 1.7, in the hope that the serious errors with this poor quality widget had been fixed. They haven't and it has AGAIN taken my entire site down. The error message I now get is:

    Fatal error: Cannot redeclare class Ai1ec_Agenda_Widget in /home/t/e/terrytwo/public_html/wp-content/plugins/all-in-one-event-calendar/app/view/admin/class-ai1ec-agenda-widget.php on line 212

    The real fatal error was mine in thinking this version might work, it doesn't. Anyone got a better one. I need to get rid of this rubbish widget and replace it soon.

  17. Yani Iliev
    Member
    Posted 1 year ago #

    @2005wcbs
    Please be respectful.
    I'd like to help you solve the problem on your website. Could you contact me by email - yani at then.ly
    I'll need admin access to your wordpress install and ftp access.

  18. Yani Iliev
    Member
    Posted 1 year ago #

    Fatal error: Cannot redeclare class Ai1ec_Agenda_Widget in /home/t/e/terrytwo/public_html/wp-content/plugins/all-in-one-event-calendar/app/view/admin/class-ai1ec-agenda-widget.php on line 212
    You need to first delete wp-content/plugins/all-in-one-event-calendar folder and then upload the one that you downloaded either from wordpress or from then.ly
    The error that you see above is a result of trying to overwrite the existing all-in-one-event-calendar with another version.

    It is safe to delete all-in-one-event-calendar folder and to upload a new version on its place.

  19. 2005wcbs
    Member
    Posted 1 year ago #

    Thank you Yani. I now have the premium version of this plug in running 1.7, and it works fine.

    I didn't know you had to remove the old version first, and not just overwrite it, that is where the problem was. Perhaps you could make that clearer, normally I think most people would just overwrite. Thanks.

  20. israel visitors guide
    Member
    Posted 1 year ago #

    Had "Cannot redeclare class Ai1ec_Agenda_Widget" error message
    whole site down

    ftp to the file that was mentioned in the error
    delete the lines in the error

    control panel up -
    install new plugin - search- all in 1 ec... - upgrade
    it reinstalled ver 1.7, site's fine now

  21. Yani Iliev
    Member
    Posted 1 year ago #

    @ israel visitors guide
    It means you overwrote the ai1ec folder, instead of first delete it and then upload the new version.
    To fix: delete the ai1ec folder via ftp and then upload the latest premium version from then.ly

  22. 2005wcbs
    Member
    Posted 1 year ago #

    One thing Yani. Since you installed 1.7 premium, I now find I am unable to upload any photos. If I deactivate All In 1, I can. It's obviously a memory problem but why would the plug in effect uploading images?

  23. Yani Iliev
    Member
    Posted 1 year ago #

    It shouldn't affect uploading photos. What kind of error do you get? Or the functionality(UI) is broken?

  24. 2005wcbs
    Member
    Posted 1 year ago #

    I thought that, but deactivating A in 1 makes it work again.

    The error message is:

    Fatal error: Out of memory (allocated 28311552) (tried to allocate 17025 bytes) in /home/t/e/terrytwo/public_html/wp-includes/functions.php on line 1038

  25. Yani Iliev
    Member
    Posted 1 year ago #

    It does look like the server is running out of memory :/
    ai1ec needs memory when parsing ics feeds, if you are not parsing ics feeds the memory consumption is not that much. I will test the memory consumption and see where we can limit and improve the memory usage. Try asking your host to double the memory on your account.

  26. 2005wcbs
    Member
    Posted 1 year ago #

    Not an option, they have already refused to do that.

  27. GardenshopAdmin
    Member
    Posted 11 months ago #

    does anyone know if there's been a solution to the all in one events calendar by timely? I tried to install and it took my site down. I tried the update install it recommends and that install failed. Or, has anyone found an alternative event calendar suggestions to use in lieu of this one that's responsive? I don't mind spending the money if it in fact works and doesn't bugger up my whole site. - thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags