WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Aleph] Dashboard Disappearance (4 posts)

  1. vividlilac
    Member
    Posted 5 years ago #

    I have been trying to figure out a cause for a problem that I was having the with NextGEN Gallery thumbnail management and finally tracked it down to a conflict with the El-Aleph plugin. I am not sure what is happening within Aleph to cause the JCrop javascript used in NextGEN to not work properly, but it seems like the javascript is not loading at all. When I disable Aleph, the JCrop works perfectly.

    Also, my error log in the NextGEN gallery directory is reporting errors:

    PHP Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'aleph_hook_custom_vars' was given in /home/xxxx/xxxx/xxxx/wp-includes/plugin.php on line 339

    PHP Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'aleph_settings' was given in /home/xxxx/xxxx/xxxx/wp-includes/plugin.php on line 339

    PHP Warning: Cannot modify header information - headers already sent by (output started at /home/xxxx/xxxx/xxxx/wp-includes/plugin.php:339) in /home/xxxx/xxxx/xxxx/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 606

    I am using:

    El-Aleph: 0.8.1
    NextGEN Gallery: 1.3.1
    Wordpress: 2.7.1

  2. vividlilac
    Member
    Posted 5 years ago #

    Darn it, messed up on the subject title... Sorry about that!

  3. Detective
    Member
    Posted 5 years ago #

    Thanks for your report, I will check it out. I'm already working in a new version, but it will be ready at least a month from now ...

  4. luksiemce
    Member
    Posted 5 years ago #

    I have similar problem.
    When i click on navigation button on some page [<][1][2]...[>] (on users page and on page with gallery from NextGEN) browser reporting errors:

    Warning: call_user_func_array(): First argument is expected to be a valid callback, 'aleph_hook_custom_vars' was given in /apache/apache-common/virt/virtuals/virt-650803/unicar/wp-includes/plugin.php on line 339 Warning: call_user_func_array(): First argument is expected to be a valid callback, 'aleph_settings' was given in /apache/apache-common/virt/virtuals/virt-650803/unicar/wp-includes/plugin.php on line 339

    WordPress: 2.8
    El-Aleph: 0.8.1
    NextGEN Gallery: 1.3.3

    I bypassed it in NextGEN by disabled pagination and in aleph by change "show_navigation" to "false" and adding to users.php:

    $il = get_found_user_pages();
    if($il>1) {
       echo 'PAGE: <a href="http://.../index.php?user_view=all">[1]</a> ';
       for ($i=2; $i<=$il; $i++) {
          echo '<a href="http://.../index.php?user_view=all&paged=' . $i . '">[' . $i . ']</a>';
       }
    }

    As yet it's working but it's not solving the problem.
    Thanks for any helping replies.

Topic Closed

This topic has been closed to new replies.

About this Topic