WordPress.org

Ready to get started?Download WordPress

Forums

Akismet
[resolved] Settings broken in Multisite (25 posts)

  1. Aaron
    Member
    Posted 1 year ago #

    Just a heads up that since 2.5.5 the settings/key screen/page is broken in WordPress multisite. All users, even super admin get an "insufficient Permissions" wp_die error.

    http://wordpress.org/extend/plugins/akismet/

  2. Samatva
    Member
    Posted 1 year ago #

    I had the same issue - just deleted (moved) the akismet folder from /wp-content/plugins

    Haven't tried 2.5.6 to see if it's fixed, but no mention in the changelog...

    Drove me nuts for a bit, as I was quite sleep-deprived and was about to totter off to bed when I updated 3 plugins and hit the error...

  3. Jason Lemahieu (MadtownLems)
    Member
    Posted 1 year ago #

    I've just confirmed the issue with 3.4 and Akismet 2.5.6 for what it's worth.

    The Akismet Configuration option doesn't show up under the Plugins menu (likely because the permissions check is returning False). If you follow the link to the settings page from the Plugins page, you'll get the die page that says you don't have permission to be here. :/

  4. Joseph Scott
    Member
    Plugin Author

    Posted 1 year ago #

    Could you provide more details on what exactly is failing. I've got a MS install using WP 3.4 and the latest Akismet and I'm able to get to the /wp-admin/admin.php?page=akismet-key-config page as a super admin just fine.

  5. Jason Lemahieu (MadtownLems)
    Member
    Posted 1 year ago #

    When logged in as a network admin, and I visit /wp-admin/?page=akismet-key-config, I get "You do not have sufficient permissions to access this page.", just like OP.

    Not sure what other details I can give you... got suggestions?

  6. Jason Lemahieu (MadtownLems)
    Member
    Posted 1 year ago #

    Update: I'd disabled all other plugins but not cleaned up my mu-plugins. I no longer have the issue and have confirmed it works as expected on a fresh install.

    Thanks for taking time to respond!

  7. Sergey Biryukov
    Trac Moderator
    Posted 1 year ago #

    /wp-admin/?page=akismet-key-config works fine for me.

    However, in network admin, when Akismet is network activated, the link in the plugin description looks like this:
    /wp-admin/network/admin.php?page=akismet-key-config

    And that link gives the permissions error.

  8. Jason Lemahieu (MadtownLems)
    Member
    Posted 1 year ago #

    Great catch, Sergey!

  9. Joseph Scott
    Member
    Plugin Author

    Posted 1 year ago #

    Interesting about the network admin link. I'll see about re-creating that and then tracking down a fix.

  10. Joseph Scott
    Member
    Plugin Author

    Posted 1 year ago #

    Ok, I see where that link is coming from. It is part of the text description for the plugin.

    Since that link isn't part of the regular code there isn't a good way to conditionally change it based on viewing in the network admin. So for now this isn't going to change. I'm not sure that removing the text (the other option) would be that helpful.

  11. Sergey Biryukov
    Trac Moderator
    Posted 1 year ago #

    Perhaps it would be possible to actually add a network admin page with a text explaining that one should visit the individual sites' configuration pages.

  12. Jason Lemahieu (MadtownLems)
    Member
    Posted 1 year ago #

    You can also get to this error page by doing the following:

    Visiting /wp-admin/plugins.php on a site where Akismet is NOT activated. The link to the configuration page is still there in the description, but following it takes you to a Permission Denied page.

    Perhaps the best fix is to remove the link from that section, and put it with the Action Links in the other column, where it can be controlled through plugin code via filters, not show up on the network admin, and only be present when the plugin is active.

  13. Joseph Scott
    Member
    Plugin Author

    Posted 1 year ago #

    Both reasonable suggestions, I'll see what we can do for the next release.

  14. Joseph Scott
    Member
    Plugin Author

    Posted 1 year ago #

    Give this patch a try - http://plugins.trac.wordpress.org/attachment/ticket/1542/akismet.diff - let me know what you think.

  15. Sergey Biryukov
    Trac Moderator
    Posted 1 year ago #

    The patch looks good. Now it's only possible to visit the configuration page if the plugin is activated.

  16. RonStrilaeff
    Member
    Posted 1 year ago #

    Should I try to install that patch or wait for an update to the plugin?

    One more bug I noticed is the subsites see the plugin as activate-able even after the "Network Activate" was done, but before the mainsite config page was found and the key entered.

    After the key was entered, the Akismet plugin disappeared from the subsites' plugin list (which is good).

    But now, one of my subsites still says that I need to enter my key. Do I need to enter the key into every subsite? If true, I'd like to make a suggestion: I think a more consistent design would be that the network super admin should be able to enter the key once for all subsites if it was network activated. As it is, when network activated, an "invalid" error shows up on every subsite dashboard.

  17. trejder
    Member
    Posted 1 year ago #

    @all: This case (except for RonStrilaeff's reply) has been discussed 4 months ago and the link in Network admin is still broken, leading to "Access Violation" error message. Haven't you fixed this yet / updated Akismet plugin for such long time?

    @RonStrilaeff: No way, their going to do this, because this is bad. Most people uses WordPress Network to manage own network of blogs from one general dashboard (with registration of new sites disabled by default). But think about those, who run sites like WordPress.com, which are open for registration of new sites. Admins of such networks for sure require, that end-point users enter own Akismet API key as they don't want hits from user sites to enlarge hits counter of their own Akismet account. Especially, if they're enterprises and had to pay for API key and will have to pay extra in pay-per-call mood, once their network overall hits count passes certain limit (of 100k hits per day, if I'm not mistaken). So for such installations having abillity of entering different API Keys per different sites is surely most welcome.

  18. RonStrilaeff
    Member
    Posted 1 year ago #

    @trejder Good point. That does make sense for someone who is setting up a mini host or community of bloggers as the original design (ie: wordpress.com) was conceived. I can live with entering it for each of "my" subsites. Thanks.

  19. sugartoys
    Member
    Posted 1 year ago #

    well i will let the plugin on the server deactivated untill a update come across to fix this. i understand the aproch of having independant API for each blog on MU but NOT ALWAYS is the same case. some people run multisites with really simple settings to their users to avoid clients/users not wp savy to let them know they need to signup for an API key and put it there and so on (i want to avoid that). I was looking foward to config the whole network with 1 API with this plugin http://wordpress.org/extend/plugins/akismet-wedge-for-mu-plugin/

    anyway, ill wait. please uptade this threat when it get fix please or IF a workaround happend or else.

    thnx guys for stepping!

  20. sugartoys
    Member
    Posted 1 year ago #

    hi guys i found this post for a workaround, didnt try it yet. just in case someone else looking for this

    http://wordpress.org/support/topic/plugin-akismet-wedge-for-mu-plugin-there-is-an-easier-solution-to-the-problem-this-plugin-tries-to-solve?replies=3

    i will try it tomorow.

  21. trejder
    Member
    Posted 1 year ago #

    This solution looks great (though I've already entered my Akismet API for each of my network's site). But it doesn't change the fact, that bug menioned in this thread should be fixed ASAP! :]

  22. adityabajaj
    Member
    Posted 1 year ago #

    Hello, I am still not sure what is the conclusion. Please could you summarize?
    I cant see the akismet in my WordPress multisite dashboard (either network or individual site). It used to work earlier.
    Thanks for your help.

  23. vanluc88
    Member
    Posted 1 year ago #

    great post.
    thanks for your help

  24. adityabajaj
    Member
    Posted 1 year ago #

    OK my solution, (if it may help someone else) to fix it, was to reload the akismet folder in plugins directory with latest akismet files. It's fixed.

  25. RavanH
    Member
    Posted 1 year ago #

    Same here. Weird issue that keeps coming up from time to time. Not sure because I usually find out later but it seems to start after a WP core upgrade.

    Tried about anything but only after:
    1. Deleting the akismet plugin folder
    2. Reinstalling it throught the WP plugin installer
    3. and then Network Activate it (this was not needed before!?!)
    all is working again...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags