WordPress.org

Ready to get started?Download WordPress

Forums

Akismet Privacy Policies
[resolved] Pligin arbeitet nicht mit iNove 1.4.6 (21 posts)

  1. t4c
    Member
    Posted 3 years ago #

    Hi,

    leider arbeitet das Plugin nicht mit iNove 1.4.6 zusammen, es wird keine Checkbox gebaut. Ich denke das Theme ist oftmals in Verwendung und ein Fix waere klasse.

    http://wordpress.org/extend/plugins/akismet-privacy-policies/

  2. t4c
    Member
    Posted 3 years ago #

    Hi nochmals,

    ich erweitere das ganze einfach nochmals um ein paar Infos.
    Ich habe natuerlich die Anleitung gelesen und
    <?php do_action( 'akismet_privacy_policies' ); ?>
    im Theme eingefuegt:

    <?php if (function_exists('highslide_emoticons')) : ?>
                                    <div id="emoticon"><?php highslide_emoticons(); ?></div>
                            <?php endif; ?>
                            <input type="hidden" name="comment_post_ID" value="<?php echo $id; ?>" />
                            <div class="fixed"></div>
                    </div>
            </div>
            <?php do_action('comment_form', $post->ID); ?>
            </form>
            <div class="privacy policy">
                    <?php echo('begin'); ?>
                    <?php do_action( 'akismet_privacy_policies' ); ?>
                    <?php echo('end'); ?>
            </div>
            <?php if ($options['ctrlentry']) : ?>
                    <script type="text/javascript">MGJS.loadCommentShortcut();</script>
            <?php endif; ?>
    
    <?php endif; ?>

    Die Echos hab ich als Markierung gesetzt, damit man sehen kann, dass die Aenderung da sein muesste, jedoch finde ich nur die beiden Eintraege, das do_action scheint komplett ignoriert zu werden, Plugin wurde aktiviert. Zu sehen ist das Ganze auf: https://www.ghcif.de/2011/04/mved-1-2-files-und-gentoo-ebuild/#respond und natuerlich auch in allen anderen Kommentaren, ueber Hilfe waere ich sehr erfreut, leider habe ich wie man vielleicht sehen kann von PHP Programmierung keine Ahnung.

    LG
    Milan

  3. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    @t4c: scheint nun aber zu klappen, die der Hinweis ist da und auch deine Kontrollausgabeb, siehe Screenshot: http://awesomescreenshot.com/0b5cc25e3
    Vermutlich bist du geloggt und daher als User bekannt, womit der Hinweis nicht dargestellt wird. Steht aber auch so in der Hilfe bei den Einstellungen, schaue mal.

  4. t4c
    Member
    Posted 3 years ago #

    @Frank Ja scheinbar spielte mir hier mein Caching Plugin einen boesen Streich und hatte daher zwar End und Begin ausgegeben, aber leider die Policy Checkbox nicht.
    Macht fuer mich zwar nun wenig Sinn, aber es laeuft... Automagic :)

    Danke!

  5. t4c
    Member
    Posted 3 years ago #

    Tja, leider muss ich einen Reopen machen.
    Das Plugin an sich gibt eine Ausgabe, jedoch bewirkt die Checkbox nichts. Auch wenn diese aktiviert ist, kommt die Fehlerausgabe.

    Geprueft auf Chromium und Firefox. WP-Caching deaktiviert.

    Es koennen gerne Testkommentare auf der Seite hinterlegt werden.

  6. unimatrixzero
    Member
    Posted 3 years ago #

    @t4c
    Bei mir das selbe, nachdem ich den php quelltext eingebaut habe wird die Checkbox mit den Datenschutzhinweisen angezeigt und man kann auch den "Haken" setzen aber nach dem Absenden des Kommentars eben:

    Achtung: Du hast die datenschutzrechtlichen Hinweise nicht akzeptiert.

    Geprueft auf Chromium und Firefox Konquerror. WP-Caching deaktiviert.

  7. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    Es ist wichtig, dass der PHP-Code innerhalb des Formulars ist, also am besten direkt vor </form> einfügen, dann sollte alles passen. ich werde die Doku ergänzen, Betriebsblind ;)
    bei dem Bsp. von t4c sieht das dann wie folgt aus:

    <?php if (function_exists('highslide_emoticons')) : ?>
                                    <div id="emoticon"><?php highslide_emoticons(); ?></div>
                            <?php endif; ?>
                            <input type="hidden" name="comment_post_ID" value="<?php echo $id; ?>" />
                            <div class="fixed"></div>
                    </div>
            </div>
            <?php do_action('comment_form', $post->ID); ?>
            <div class="privacy policy">
                    <?php echo('begin'); ?>
                    <?php do_action( 'akismet_privacy_policies' ); ?>
                    <?php echo('end'); ?>
            </div>
            </form>
            <?php if ($options['ctrlentry']) : ?>
                    <script type="text/javascript">MGJS.loadCommentShortcut();</script>
            <?php endif; ?>
    
    <?php endif; ?>
  8. t4c
    Member
    Posted 3 years ago #

    Funktioniert leider immer noch nicht. Ist nun wie beschrieben in den Formtags, aber ich bekomme immer noch die Meldung

    Achtung: Du hast die datenschutzrechtlichen Hinweise nicht akzeptiert.

    <div class="fixed"></div>
                    </div>
            </div>
            <?php do_action('comment_form', $post->ID); ?>
                    <?php do_action( 'akismet_privacy_policies' ); ?>
            </form>
            <?php if ($options['ctrlentry']) : ?>
                    <script type="text/javascript">MGJS.loadCommentShortcut();</script>
            <?php endif; ?>
    
    <?php endif; ?>

    so mein Code.

  9. Roy
    Member
    Posted 3 years ago #

    Guys, there's also a forum for German speaking WP users.
    http://forum.wordpress-deutschland.org/

  10. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    @t4c: i have test this in your theme, see code:

    </div>
    	<?php do_action('comment_form', $post->ID); ?>
    <?php do_action( 'akismet_privacy_policies' ); ?>
    	</form>

    works fine; you can also send me an mail, when you have also this problem.

  11. t4c
    Member
    Posted 3 years ago #

    This is the same method I tried which seems not to work like you can test on ghcif.de

  12. t4c
    Member
    Posted 3 years ago #

    http://nopaste.info/1de0a1c890.html here the complete comments.php, don't wanna shred this thread.

  13. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    What is your wp version? Maybe we have an problem with the hook.

  14. unimatrixzero
    Member
    Posted 3 years ago #

    @Frank

    WordPress 3.1.2 here in use... with iNove 1.4.6.. I know that t4c use the same version of this Templet but I don`t now witch Version of Word Press he use. But I guess it is the 3.1.2 and we have the same issues....

  15. t4c
    Member
    Posted 3 years ago #

    I am using WordPress 3.1.2, always up to date :)

  16. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    hmm
    I have also tested on a other client, works fine with the theme inove form wp.org-Theme.Directory. Please see also my source from the comments.php, i have download and add my hook to the comments.php
    https://gist.github.com/953797

  17. t4c
    Member
    Posted 3 years ago #

    Hi Frank,

    just copied your source, deleted my comments.php edited a new one, problem still exists.

  18. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    Maybe it is possible i get an account, ftp rights ? I will debug the hook. (via Mail - bueltge.de/impressum/)

  19. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    The problem was in the cache from plugin Hyper Cache. It is important, that you refresh cache after add code to template.

  20. t4c
    Member
    Posted 3 years ago #

    Thanks to Frank, support can't be better!

  21. unimatrixzero
    Member
    Posted 3 years ago #

    Thanks to Frank too, now it works!!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic