WordPress.org

Ready to get started?Download WordPress

Forums

Ajaxize
[resolved] Problems with wp-login.php (6 posts)

  1. ovidiubica
    Member
    Posted 2 years ago #

    Hello, congrats on this awesome plugin. I used it with W3-Total-Cache and Classipress Theme and it does the job pretty well.

    I do have a big problem though. On the login screen (custom), the plugin is loading the site in an infinite loop in those ajaxied widgets placed in footer.

    Also, the widgets don't show up at all on 404 page.

    Any ideea about this behaviour?

    http://wordpress.org/extend/plugins/ajaxize/

  2. yoav.aner
    Member
    Plugin Author

    Posted 2 years ago #

    Hi ovidiubica,

    Thanks for dropping by. Ajaxize was conceived when I had to load some dynamic plugin data, but W3-Total-Cache was caching it. I'm happy it works for you too.

    I'm not sure exactly how/where you use ajaxize that it causes the problems you've described. If you can give some more info I'd be happy to try and see why this happens. That said, I can't promise anything. ajaxize is very simple and isn't exactly meant to deal with too-complex scenarios, and I'd like to keep it this way. So perhaps it's not suitable for everything. In any case, I'd be happy to try and help and potentially improve my plugin.

  3. yoav.aner
    Member
    Plugin Author

    Posted 2 years ago #

    Hi ovidiubica,

    I think I found the issue you were experiencing with the 404 page. The reason why it doesn't work is because ajaxize always calls the same page that you're on, so if you're calling it on a 404 page, it also returns 404, so the javascript fails.

    In any case, I've tried a few things and think I have a fix. Are you able to try it?

    Go to plugins->Editor. Choose the Ajaxize plugin and edit ajaxize_this.js file. Simply replace the content with http://pastebin.com/4gYAFCTQ

    I tested it and it seems to work, but I'd be grateful if you could let me know if it also works for you.

  4. ovidiubica
    Member
    Posted 2 years ago #

    I tested the new javascript and it seems to work for 404 page now except if you have more than 1 ajaxized widget (in my case 3) it outputs the content of the first to all 3 widgets.

    As for my custom login form, it still loops the entire site in each widget. I suspect its due to the redirect from the core wordpress login to the custom one.

    You're getting closer. Keep up the good work.
    Ovidiu

  5. yoav.aner
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ovidiu,

    Thanks for the feedback. I think I may have a solution for the 404 page ( try http://pastebin.com/hy5dK3Kz ). I have to admit, whilst it's nice to be able to use ajaxize on any page, 404 pages are usually excluded from caching, so there's little benefit from ajaxizing anything on those. So I'm not sure whether to include this javascript fix on the next version of ajaxize...

  6. yoav.aner
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ovidiu,

    I've figured out a way to include this fix without affecting non-404 pages. It's now included in version 1.3. Thanks again for letting me know about this issue (I also gave you credit for reporting it on the plugin description and changelog).

    Cheers
    Yoav

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags