WordPress.org

Ready to get started?Download WordPress

Forums

AJAX Thumbnail Rebuild
Unable to insert non-rebuilt images (4 posts)

  1. joker23
    Member
    Posted 3 years ago #

    I noticed that if you do not have thumbnail, medium and large sizes checked when rebuilding the thumbnails you will be unable to insert those sizes when editing posts/pages.

    I chose to just rebuild the size I needed since the other images already existed. When I went to edit an existing post, clicked on 'upload/insert' photo, went to gallery and clicked 'show', the thumbnail, medium and large radio buttons were not selectable as if those images no longer existed though they are still in my uploads folder. I tested by selecting thumbnail next time I rebuilt the thumbnails and when returning to the gallery I was able to select thumbnail.

    Is there a way to fix this? I like the idea of selecting which sizes to rebuild, but not worth it if it's going to affect my ability to insert photos in posts/pages.

    http://wordpress.org/extend/plugins/ajax-thumbnail-rebuild/

  2. Manuel Schmalstieg
    Member
    Posted 3 years ago #

    Same issue here, running WP 3.1-RC2-17258. I wanted only the medium size to be regenerated, but after doing so the connection to thumbnail sizes seems to be "broken" (so instead of thumbnails the full size was loaded). The images are still there, but for some reason WP isn't aware of the older sizes.

    So it seems that we have to rebuild all images (which is also what the "Regenerate Thumbnails" plugin is doing). Maybe a limitation of the internal WP thumbnail function?

  3. tehovinha
    Member
    Posted 3 years ago #

    Having the same problem :( Hope that there will be a fix soon.

  4. senator94
    Member
    Posted 3 years ago #

    WordPress 3.2.1 same thing happen to me. Hopefully, there is a fix for this because I have over 7000 images.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic