WordPress.org

Ready to get started?Download WordPress

Forums

AJAX Thumbnail Rebuild
[resolved] Only one thumbnail size works (4 posts)

  1. AlexLakes
    Member
    Posted 3 years ago #

    Hi, So I have two thumbnail sizes defined (the default and a new size):
    'add_theme_support( 'post-thumbnails' );
    set_post_thumbnail_size(200, 100, true);
    add_image_size( 'related-thumbnail', 100, 100, true ); // W, H, hard crop mode true

    And if I regenerate one at a time, only the most recently generated size displays properly. If I regenerate both thumbnail sizes at the same time, only the 200x100 thumbnail works properly.

    In both cases with the thumbnail that does work, it's as if WordPress doesn't know that that image size exists b/c it links to the original sized image. Does this have anything to do with WordPress thumbnail meta being destroyed like with this other plugin? http://wordpress.org/support/topic/plugin-regenerate-thumbnails-broken-badly

    WP 3.0.3, AJAX thumbnail rebuild v1.03

    http://wordpress.org/extend/plugins/ajax-thumbnail-rebuild/

  2. AlexLakes
    Member
    Posted 3 years ago #

    Is it possible that this plugin is not compatible with (properly) renamed and moved wp-content and plugin folders? http://codex.wordpress.org/Editing_wp-config.php#Moving_wp-content

  3. AlexLakes
    Member
    Posted 3 years ago #

    I figured it out. For some reason calling the thumbnail by its specified name doesn't work:
    the_post_thumbnail( 'related-thumbnail' );

    But if I call it using an array, it works:
    the_post_thumbnail( array(100,100) );

    So this seems to be an issue with WordPress afterall, not your plugin.

  4. ecurtain
    Member
    Posted 3 years ago #

    AlexLakes, thank you, thank you. I've been trying to get the custom thumbnail sizes to size & crop correctly and this was just the thing I was missing.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic