WordPress.org

Ready to get started?Download WordPress

Forums

AG Custom Admin
Stop plugin from outputting version number (2 posts)

  1. gotmedia
    Member
    Posted 2 years ago #

    I read that it's a bad idea for hackers to know which version of WordPress you're running and so, as I was taking look in between my <head>, I noticed this script there:

    <script type="text/javascript">
    var wpversion = "3.4.1";
    var agca_version = "1.2.6.4";
    var jQueryScriptOutputted = false;
    var agca_context = "page";
    function initJQuery() {
    //if the jQuery object isn't available
    if (typeof(jQuery) == 'undefined') {
    	if (! jQueryScriptOutputted) {
    		//only output the script once..
    		jQueryScriptOutputted = true;
    		//output the script (load it from google api)
    		document.write("<scr" + "ipt type=\"text/javascript\" src=\"http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js\"></scr&quot; + "ipt>");
    	}
    	setTimeout("initJQuery()", 50);
    } else {
    	jQuery(function() {
    		try
    		{
    			jQuery('#wpadminbar').show();
    			if(isWPHigherOrEqualThan("3.3")){ }
    
    			if(isWPHigherOrEqualThan("3.3")){
    			}
    
    			jQuery("#wphead #header-logo").css("display","none");
    			jQuery("ul#wp-admin-bar-root-default li#wp-admin-bar-wp-logo").css("display","none");
    		}catch(ex){}
    	});
    }
    }
    initJQuery();
    </script>

    How do I resolve this?

    http://wordpress.org/extend/plugins/ag-custom-admin/

  2. argonius
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    This is required for the AGCA plugin to work properly, because it should support different WordPress versions. I would say that this is not something to be concern about. There are many other traces that WordPress leaves about the WP version, like in head:

    <meta name="generator" content="WordPress 3.4.1" /> or in resources like CSS and JS

    but even without it, it wouldn't be difficult to guess which WP version is there.

    If you still have any concerns about it, please don't use it.

    Thanks,
    Argonius

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic