WordPress.org

Ready to get started?Download WordPress

Forums

AG Custom Admin
[resolved] AG custom admin cannot be activated: "require ... FirePHPCore" p (7 posts)

  1. thecondordb
    Member
    Posted 2 years ago #

    When I updated the AG custom admin plugin to the current version, I got this error (while trying to reactivate the plugin):

    Warning: require_once(/../../../../FirePHPCore/lib/FirePHPCore/fb.php) [function.require-once]: failed to open stream: No such file or directory in /kunden/330468_40233/webseiten/wp-content/plugins/ag-custom-admin/plugin.php on line 26

    Fatal error: require_once() [function.require]: Failed opening required '/../../../../FirePHPCore/lib/FirePHPCore/fb.php' (include_path='.:/usr/local/lib/php') in /kunden/330468_40233/webseiten/wp-content/plugins/ag-custom-admin/plugin.php on line 26

    Regards,

    Dennis aka thecondordb

    http://wordpress.org/extend/plugins/ag-custom-admin/

  2. argonius
    Member
    Plugin Author

    Posted 2 years ago #

    I am sorry for this mistake. You could fix it by removing line 26 from ag-custom-admin/plugin.php, or simply download new AGCA version 1.2.5.4 with patch for this issue.

    Thanks.

  3. thecondordb
    Member
    Posted 2 years ago #

    I just made the automatic update to AG custom admin plugin version 1.2.5.4 and got this error in a Javascript alert box:

    AGCA - ADMIN ERROR: ReferenceError / isWPHigherOrEqualThan is not defined

    After that, the plugin seems to be activated but I permanently get the same error on every admin page. If I open the AG custom admin plugin page in my admin interface, the same error is displayed on the top in red color:

    WARNING: AG Custom Admin stops its execution because of an error. Please resolve this error before continue:

    AGCA - ADMIN ERROR: ReferenceError / isWPHigherOrEqualThan is not defined

    The plugin became unusable.

    Regards,

    Dennis aka thecondordb

  4. argonius
    Member
    Plugin Author

    Posted 2 years ago #

    This problem is related to cached data. Just clear browser's cache and try again.

    I'm realy sorry for this. Caching problem made many headaches to me, but I finally found solution for this, and will include it in next release. Caching problem should be history.

    I apologize for this, and problems you have been experiencing. Hope you would keep using AG Custom Admin in future.

    Argonius

  5. thecondordb
    Member
    Posted 2 years ago #

    Thanks for the info.

    I cleared my cache and the plugin does not report errors anymore and is usable.

    However NOW my admin bar is gone (white blank space) when looking at the front end of the blog (e.g. my blog home page) – if I'm in the admin interface the admin bar is visible and ok.

    Regards,

    Dennis aka thecondordb

  6. argonius
    Member
    Plugin Author

    Posted 2 years ago #

    That's true. It's not implemented yet, and is more like new feature than a bug. You could display admin top bar on site pages by changing

    function print_page()
    	{
    		?><style type="text/css">
    		#wpadminbar{
    			display:none;
    		}
    		</style><?php
    	}

    to

    function print_page(){}

    on line 314 in ag-custom-admin/plugin.php

    Problem is that styles would not be applied on it and default WordPress top bar styles should be applied instead.

    This would be implement in future releases.

    Argonius

  7. thecondordb
    Member
    Posted 2 years ago #

    Thanks. This worked.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic