WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Excerpt
"Read the Rest" appears first if Graphic/Link if First in Docum (6 posts)

  1. paulrainbow
    Member
    Posted 2 years ago #

    Love this Plugin. I have done a little bit of searching but I haven't found a solution.

    I have some pages which the "Read the Rest" appears correctly after the text of the excerpt and others where it appears BEFORE the excerpt.

    Example of the Problem and Correct:
    http://www.hsufootball.com.au/2012/category/rego/rego_day/

    I have done a little bit of testing, and it looks like the problem relates to when an Image or Hyperlink is the first thing on the post and not text.

    http://wordpress.org/extend/plugins/advanced-excerpt/

  2. davert
    Member
    Posted 1 year ago #

  3. computersimple
    Member
    Posted 1 year ago #

    Actually I didn't find it resolved in the last link provided. I did find I was having this same problem, however, and the solution is in the allowed html tags. For example if you allow <table><tr><td> etc...
    but your excerpt is cutoff before the tags are closed then the read the rest does not fall in line with the text, it is thrown off by the unclosed tags, same is most likely true for <p> <form> or others that need to be closed.

    To solve the problem for me I changed my allowed html tags in the Excerpt settings. Or if you want to be super-mindful when creating posts note the length of the excerpt and what tags need to be closed before you hit that limit...

    I'm not sure if in future releases of this plugin it would be possible to have an option that would 'automatically close any open html tags' but this would be a great fix if it is possible.

    Thanks, and love this plugin!

  4. makedesign
    Member
    Posted 1 year ago #

    The problem seems to be related to allowing elements that require the HTML markup to both open and close... For instance, allowing "a", "strong", "em", "i", etc. elements causes the bug where the "Read More" shows up inside the element (not at the end of the excerpt).

    I'm guessing it's because the function is appending the "Read More" link inside that element when it closes... I haven't checked the code out yet to verify.

    Self-closing elements (like images, HRs, etc.) don't seem to have the issue as they don't require a closing tag. I can allow images and the "Read More" link shows up at the end of the excerpt just fine.

    I worked around this by just stripping the formatted text elements that I wanted to add... which is a step backwards, but still allows me control over how many characters are used and the other features that the plugin still does well.

    Hoping for a fix soon!

  5. cihat74
    Member
    Posted 1 year ago #

    I was struggling with this and finally achieved by the magic of a tiny "dot". Let me tell you what I did.

    My users send posts via a form made by Gravity Forms. On the top of the the posts I had a table added automatically. I tried almost all the options in Advanced Excerpt. Then finally found out that it worked by putting a "." where the table tag ends. That worked in my case. Hope it helps some of you.

    Instead of telling here, the best way will be showing with pictures.

    1- AE Options Page

    2- Post Content Page

    3- The Result Page

  6. cihat74
    Member
    Posted 1 year ago #

    Hımm! Made something wrong and realized another thing. While in the html view of my automated post I saw it starts like that:

    <br/>
        <table border="1"....

    SOLUTION:
    When I removed the line break:

    <br/><table border="1"....

    VOILA, it is below the table. So I will try to find how to prevent wordpress giving a line-break automatically.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic