WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Excerpt
More link is preceding text...? (7 posts)

  1. wp-digiman
    Member
    Posted 2 years ago #

    So... this is weird. Installed the plugin - love it, for the most part - to get some of my html tags from posts passed to the excerpt.

    But then, I realized that the resulting generated excerpt listing has the ellipsis/'read more' link at the *front* of the displayed text... rather than at the end. Sort of like this:

    ...Read More... Here's the very beginning of the post content, followed by more and more and more until it is cut off by the Advanced Excerpt length

    rather than:

    Here's the very beginning of the post content, followed by more and more and more until it is cut off by the Advanced Excerpt length...Read More...

    I've been digging through the forums and Google, and haven't found anyone else mentioning running into this.... What could I be doing wrong?

    http://wordpress.org/extend/plugins/advanced-excerpt/

  2. psteinweber
    Member
    Posted 2 years ago #

    I'm having the same problem since the update to WordPress 3.3.1 (updated straight from 3.2, skipped 3.3).
    I discovered that links really mess the read more logic up, and the read more appears after every link (I activated links for the excerpt, that'ts waht I'm using this plugin for)

    Any solutions out there?

  3. basvd
    Member
    Posted 2 years ago #

    The plugin tries to place the link inline with the text. This usually works well, but apparently not all the time.

    It would be very helpful if you could post HTML source code of the generated excerpt and the original post (at least the part that is included in the excerpt), so I can try to reproduce the problem and hopefully fix it.

    Thanks in advance!

  4. psteinweber
    Member
    Posted 2 years ago #

    hi,

    sorry for the late reply, I was traveling.
    here is the sourcecode from the website, with the wrong placed "read more" link (in this case "weiter...")

    <p>Mein spiritueller Lieblingslehrer <a title="Leben im Jetzt, aber wie?" href="http://www.newslichter.de/2011/05/leben-im-jetzt-aber-wie/" target="_blank">Eckhart Tolle <a href="http://www.newslichter.de/2012/01/eckhart-tolles-uncourse-online/" class="read_more">(weiter…)</a></a> hat mit UnCourse eine Online-Tool entwickelt, um die Integration von seinen Lehren ins Leben zu erleichtern. Der UnKurs ist kostenlos und jeder kann nach einer Registrierung teilnehmen. Warum ein so genannter “Uncourse “? Er wird</p>

    The excerpt is being generated out of this code, which comes from the wordpress post editor:
    Mein spiritueller Lieblingslehrer <a title="Leben im Jetzt, aber wie?" href="http://www.newslichter.de/2011/05/leben-im-jetzt-aber-wie/" target="_blank">Eckhart Tolle</a> hat mit UnCourse eine Online-Tool entwickelt, um die Integration von seinen Lehren ins Leben zu erleichtern. Der UnKurs ist kostenlos und jeder kann nach einer Registrierung teilnehmen. Warum ein so genannter "Uncourse "? Er wird nicht als Mittel zum Zweck angeboten, sondern als Erinnerung. <!--more-->Es soll helfen, die wahre Quelle des Friedens und der Freiheit in sich selbst zu entdecken und zu halten. Zitat: "Folgen Deiner Intuition und lassen ihn navigieren zu einem Kurs auf Deinem Weg,  der Dich am besten unterstützt."

    - it worked fine before the wordpress update!

    Thanks,
    Philipp

  5. davert
    Member
    Posted 1 year ago #

    I find it does this for colons and semi-colons. I looked at the code and don't see why it would do this.

  6. makedesign
    Member
    Posted 1 year ago #

    Here's some notes and a possible workaround for anyone encountering this.

    The problem seems to be related to the individual elements that you allow within your excerpt... I can't really nail down exactly what's causing this, but every time I tried to allow individual elements (b, strong, img, a, etc...), it added the "Read More" link inside the first formatted element that it found...

    ie: if I allowed "strong" and I used "strong" text in my excerpt, it added the link inside the "strong" tag. Lame. Same story for links and a handful of other elements that I tried out. EXCEPT for images... if I have an image in my excerpt and I just allow the "img" element, it works just fine... so maybe this is an issue only with formatted text elements that require the HTML markup to both open and close... not self-closing elements like images, HRs, etc... This is frustrating because this is pretty much the main reason most people use this plugin, but hey, I'll take the images.

    I worked around this by just stripping the formatted text elements that I wanted to add... which is a step backwards, but still allows me control over how many characters are used and the other features that the plugin still does well.

    Hopefully the plugin author will be able to release an update to fix this :) Pretty please? I understand a WP update may have screwed this up, so it's totally understandable if it takes time to get around to fixing this. If you get to this, you rock!

    Thanks to this thread for the solution (or at least a workaround): http://wordpress.org/support/topic/plugin-advanced-excerpt-read-the-rest-appears-first-if-graphiclink-if-first-in-document

  7. makedesign
    Member
    Posted 1 year ago #

    Adding this for clarity (and hoping someone runs across an actual fix now that we've narrowed down the cause):

    The problem seems to be related to allowing elements that require the HTML markup to both open and close... For instance, allowing "a", "strong", "em", "i", etc. elements causes the bug where the "Read More" shows up inside the element (not at the end of the excerpt).

    I'm guessing it's because the function is appending the "Read More" link inside that element when it closes... I haven't checked the code out yet to verify.

    Self-closing elements (like images, HRs, etc.) don't seem to have the issue as they don't require a closing tag. I can allow images and the "Read More" link shows up at the end of the excerpt just fine.

    I worked around this by just stripping the formatted text elements that I wanted to add... which is a step backwards, but still allows me control over how many characters are used and the other features that the plugin still does well.

    Hoping for a fix soon!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic