WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Excerpt
Excerpts not working 4.4.1 (9 posts)

  1. Toreador
    Member
    Posted 2 years ago #

    The "read more" test and ellipsis are not displaying at the end of the excerpt any more - usually they appear at the start instead, but sometimes somewhere in the middle

    http://wordpress.org/extend/plugins/advanced-excerpt/

  2. Toreador
    Member
    Posted 2 years ago #

    Update: After a bit of experimentation, I've found that it puts the "read more" text after the first image, regardless of where that image appears in the excerpt.

  3. Toreador
    Member
    Posted 2 years ago #

    And a final update: it works correctly if "Don't remove any markup" is checked, so this provides a possible work-round

  4. _toast
    Member
    Posted 2 years ago #

    I was having the same problem. The "... [read more]" was showing up in the middle of some excerpts, not the end.

    I discovered after much trial and error that if, in the Advanced Excerpt Options section, I went to the Keep Markup section and UNchecked the boxes for the following two html tags

    [em]
    and
    [strong]

    ...the plugin placed the "... [read more]" at the end of the excerpt.

    Unfortunately, I was hoping to keep the em and strong tags, which was part of the point of using a plugin (to keep the styling), but something's better than nothing!

  5. Dylan Kuhn
    Member
    Posted 2 years ago #

    I was getting the read more link placed in the middle of the excerpt, right after the second link in it. I had to exclude link tags to fix it, ending up with this:

    <?php the_advanced_excerpt('length=50&add_link=1&use_words=1&no_custom=1&ellipsis=%26hellip;&exclude_tags=div,img,p,strong,a');?>

    Again, lost functionality, but works.

  6. otakonx
    Member
    Posted 2 years ago #

    I'm having the same issue running 3.3.2 and the latest version of the plugin. Dylan, thanks for the work around. It would be nice if this great plugin worked as intended.

  7. liveland
    Member
    Posted 2 years ago #

    I was having the same problem, to solve I had to comment out the following code from the following 4 lines of code in the function called: text_add_more
    // $pos = strrpos($text, '</');
    // if ($pos !== false)
    // Inside last HTML tag
    // $text = substr_replace($text, $ellipsis, $pos, 0);
    // else
    // After the content
    $text .= $ellipsis;

    I can't see any purpose to these lines of code, and my excerpts all seem to be working correctly now.

    Please could this code be fixed permanently on the next update of this superb plugin?

    Thanks

  8. ourmaninindia
    Member
    Posted 1 year ago #

    Mmm indeed the previous post was most effective but there is a purpose to those lines. It now always add the read more comment on a new line rather that it appends.

  9. americanbiotech
    Member
    Posted 1 year ago #

    I'm running the ArjunaX theme with the latest version of wordpress. I had previously set my reading settings to show only excerpts. When landing on a results page after a search, the reader is not able to click on the three dots to read more. They have to click on the title. I've set the read settings to show the entire post but the three dots still appear and are not clickable. Please help! The site is http://www.europeanbiotechnologist.com. Searching for a word like "pcr" will give you a good idea of what I'm talking about.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic