WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Custom Fields
WYSIWYG-fields aren't saving in Drafts (8 posts)

  1. Doggie52
    Member
    Posted 2 years ago #

    Hi there!

    I've come across a problem I doubt I am the only one having. When entering things into any type of custom WYSIWYG-field created in ACF, the input is not saved when saving the post as a draft. This is a very inconvenient problem, as it forces my editors to write their articles all in one go.

    If I were more familiar with how the plug-in is coded, I might try to find the bug myself. But for the time being, I would appreciate if the author could take a look at it!

    Thanks in advance!

    http://wordpress.org/extend/plugins/advanced-custom-fields/

  2. RevConcept
    Member
    Posted 2 years ago #

    I have this same issue. I know the developer was on vacation...not sure if he's back yet. But I have a client using the site and not being able to save drafts is quite a big issue :(

  3. Doggie52
    Member
    Posted 2 years ago #

    Here's a reply that someone decided to delete:

    I have this same issue. I know the developer was on vacation...not sure if he's back yet. But I have a client using the site and not being able to save drafts is quite a big issue :(

  4. Doggie52
    Member
    Posted 2 years ago #

    I apologize for that, I did not see your reply anywhere but in my e-mail inbox and assumed you had removed it.

  5. elliotcondon
    Member
    Plugin Author

    Posted 2 years ago #

    Hey guys

    Great news! I figured out the draft bug. It's now fixed in v3.1.0

    Please remember to do a hard refresh in the edit screen to load in the new js. (you only need to do it once to clear the cache)

    Cheers
    Remember to vote!

  6. Doggie52
    Member
    Posted 2 years ago #

    Much appreciated! I've gone through your last changesets, but I can't seem to find precisely where the bug appeared and was fixed. Out of curiosity, where did you find it?

  7. elliotcondon
    Member
    Plugin Author

    Posted 2 years ago #

    JS runs when you submit a post. This js removes all the other hidden acf fields on the page.

    Prior to 3.1.0, this js was not triggered on "Save Draft". It was my own mistake of forgetting to add the js to that button.

    Now it's added and now it works!

  8. RevConcept
    Member
    Posted 2 years ago #

    You are the BEST! Thanks for correcting this so quickly. I updated the plugin and the issue is resolved.

    Do you know if this update fixed the double WYSIWYG content editor issue as well? I "hid" all of the standard content editors as a work around to the bug...just wondering if it's been fixed.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic