WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Custom Fields
WYSIWYG editor does not work in WP 3.3 (6 posts)

  1. kmai
    Member
    Posted 2 years ago #

    WYSIWYG editor does not work in WP 3.3. It shows up as a plain textarea with HTML instead.

    http://wordpress.org/extend/plugins/advanced-custom-fields/

  2. Alamoxie Web Design
    Member
    Posted 2 years ago #

    In my WP 3.3 installation, I noticed that if you change the main post editor between Visual and HTML, then the Advanced Custom Field WYSIWYG does not change immediately... but when you refresh the post edit page, it also changes types. A little inconvenient, but I can use the WYSIWYG editor in either HTML or Visual mode that way, by changing the main one at the top of the page and then refreshing. Does that help you, or does yours never change?

  3. kmai
    Member
    Posted 2 years ago #

    I have suppressed the main content editor and when I set up ACF initially, the WYSIWYG toolbars displayed as desired. When I upgraded to 3.3, they vanished. Based on a similar suggestion from the ACF support forum, I re-enabled the editor, changed it from HTML to Visual, saved, then disabled the editor again and this brought back the WYSIWYG ACF fields properly. So yes, this solution worked for me. Thank you!

  4. kmai
    Member
    Posted 2 years ago #

    Note that switching to HTML view on ANY other editor (ie. posts, pages, plugin content) and saving may make the WYSIWYG toolbars disappear again in ACF fields, even if they are on a different post type. That is what is currently happening on my WP 3.3 with ACF 3.0.4.

    You'll have to go and switch to the Visual editor somewhere and save to get them back again every time this happens. The easiest thing to try to remember is to always save things while in Visual mode, but if you ever forget, you'll need to repeat the fix.

    Obviously, this is a dangerous bug to clients, so I don't recommend using ACF for client use until this is resolved.

  5. georgefarkas
    Member
    Posted 2 years ago #

    I am having the same issue, but it's happening under a special field type that is controlled by a shopping cart plugin. No tinyMCE buttons at all.

  6. supersuphot
    Member
    Posted 2 years ago #

    Thanks for the great plugin. I have the same problem too.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic