WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Custom Fields
Custom fields not showing (6 posts)

  1. velvet_grooves
    Member
    Posted 1 year ago #

    Hi there,

    I'm developing a site for a client, and think I have PHP conflict with the custom fields plugin.

    See the code below.

    <?php
    
    /**
    
     * Template Name: Cotswolds Weddings
    
     *
    
     */
    
    get_header(); ?>
    
    <div id="page" class="hfeed">
    	<div id="main">
    
    		<div id="primary">
    			<div id="content" role="main">
    
    		<!-- Top Quote -->
    
    			<div id="quote">
    			<div class="title-top"><?php the_title(); ?></div>
    			<div class="text"><?php the_field('top_text'); ?></div>
    			</div>
    
    		<!-- Middle Content -->
    
    		<div id="middle">
    
    		<?php $my_query = new WP_Query('category_name=Weddings&showposts=5'); ?>
    		<?php $count = 0; ?>
    		<?php while ($my_query->have_posts()) : $my_query->the_post(); ?>
    		<?php $count++; ?>
    
    		<ul id="meet_the_florists">
    		<li>
    		<?php the_post_thumbnail('thumbnail', array('class' => 'weddings_thumb')); ?>
    			<div style="float:left; top:0px; width:250px;">
    				<span class="weddings-title"><?php the_title(); ?></span>
    				<div style="clear:both;"></div>
    				<span class="hotel-name"><?php the_field('hotel_name'); ?>
    				<div style="clear:both;"></div>
    				<?php the_field('hotel_location'); ?></span>
    			</div>
    			<div style="top:0px; float:right;">
    			<p class="wedding-season"><?php the_field('wedding_season'); ?>&nbsp;Wedding</p>
    			</div>	
    
    			<div style="clear:both;"></div>
    			<span class="wedding-summary"><?php the_content(); ?></span>
    			<div style="clear:both;"></div>
    
    			<div style="float:left; width:50%;">
    			<span class="photographer-name">Photographer | <?php the_field('photographer_name'); ?>
    			<br><a href="http://<?php the_field('photographer_web_link'); ?>" target="_blank"><?php the_field('photographer_web_link'); ?></a></span>
    			</div>
    
    			<div style="float:right;">
    			<span class="photographer-name">Hair and Makeup | <?php the_field('hair_makeup_name'); ?>
    			<br><a href="http://<?php the_field('hair_makup_web_address'); ?>" target="_blank"><?php the_field('hair_makup_web_address'); ?></a></span>
    			</div>			
    
    		</li>
    		</ul>
    		<?php endwhile; ?>
    		</div>
    
    		<!-- Right Column -->
    		<div id="right"><?php the_field('quote_right'); ?>
    		<ul class="ads_container">
    				<?php $my_query = new WP_Query('category_name=SideAds&showposts=2'); ?>
    				<?php $count = 0; ?>
    				<?php while ($my_query->have_posts()) : $my_query->the_post(); ?>
    				<?php $count++; ?>
    					<li id="post-<?php echo $count ?>" class="first">
    					<?php the_post_thumbnail( array(315,170) ); ?>
    					<div class="ad-li">
    					<div class="ad_title">
    					<h2><?php the_title(); ?></h2>
    					<div id="ad_text"><?php the_excerpt(); ?></div><div class="ad_link"><a href="<?php the_permalink();?>">Read More</a></div>
    				</div>
    
    					</li>
    				<?php endwhile; ?>
      					</ul>
    		</div>
    		<div style="clear:both;"></div>
    
    		<!-- Bottom Column -->
    		<div id="quote-other">
    		<div class="title-front">WEDDING FLORISTS IN THE COTSWOLDS</div>
    		<div class="text"><?php the_field('bottom_quote'); ?></div>
    		</div>
    
    			</div><!-- #content -->
    		</div><!-- #primary -->
    <?php get_footer(); ?>

    The bottom quote (<?php the_field('bottom_quote'); ?>) isn't showing. If I stick the text in manually - it'll show. But having the custom field, no success. Any ideas? This happens on a few pages, not just this one...

    http://wordpress.org/extend/plugins/advanced-custom-fields/

  2. elliotcondon
    Member
    Plugin Author

    Posted 1 year ago #

    Perhaps the global $post object is not yet instantiated. Try running the_post(); right after the_header();

    If that does not work, make sure your field names are correct.
    Also, you can try setting a second parameter of the post_id

  3. velvet_grooves
    Member
    Posted 1 year ago #

    This arrangement of code seems to work if it helps?

    <?php
    
    /**
    
     * Template Name: Cotswolds Weddings
    
     *
    
     */
    
    get_header(); ?>
    
    <div id="page" class="hfeed">
    	<div id="main">
    
    		<div id="primary">
    			<div id="content" role="main">
    
    		<!-- Top Quote -->
    
    			<div id="quote">
    			<div class="title-top"><?php the_title(); ?></div>
    			<div class="text"><?php the_field('top_text'); ?></div>
    			</div>
    
    			<div id="quote-other">
    		<div class="title-front">WEDDING FLORISTS IN THE COTSWOLDS</div>
    		<div class="text"><?php the_field('bottom_quote'); ?></div>
    		</div>
    
    		<!-- Middle Content -->
    
    		<div id="middle">
    
    		<?php $my_query = new WP_Query('category_name=Weddings&showposts=5'); ?>
    		<?php $count = 0; ?>
    		<?php while ($my_query->have_posts()) : $my_query->the_post(); ?>
    		<?php $count++; ?>
    
    		<ul id="meet_the_florists">
    		<li>
    		<?php the_post_thumbnail('thumbnail', array('class' => 'weddings_thumb')); ?>
    			<div style="float:left; top:0px; width:250px;">
    				<span class="weddings-title"><?php the_title(); ?></span>
    				<div style="clear:both;"></div>
    				<span class="hotel-name"><?php the_field('hotel_name'); ?>
    				<div style="clear:both;"></div>
    				<?php the_field('hotel_location'); ?></span>
    			</div>
    			<div style="top:0px; float:right;">
    			<p class="wedding-season"><?php the_field('wedding_season'); ?>&nbsp;Wedding</p>
    			</div>	
    
    			<div style="clear:both;"></div>
    			<span class="wedding-summary"><?php the_content(); ?></span>
    			<div style="clear:both;"></div>
    
    			<div style="float:left; width:50%;">
    			<span class="photographer-name">Photographer | <?php the_field('photographer_name'); ?>
    			<br><a href="http://<?php the_field('photographer_web_link'); ?>" target="_blank"><?php the_field('photographer_web_link'); ?></a></span>
    			</div>
    
    			<div style="float:right;">
    			<span class="photographer-name">Hair and Makeup | <?php the_field('hair_makeup_name'); ?>
    			<br><a href="http://<?php the_field('hair_makup_web_address'); ?>" target="_blank"><?php the_field('hair_makup_web_address'); ?></a></span>
    			</div>			
    
    		</li>
    		</ul>
    		<?php endwhile; ?>
    		</div>
    
    		<!-- Right Column -->
    		<div id="right"><?php the_field('quote_right'); ?>
    		<ul class="ads_container">
    				<?php $my_query = new WP_Query('category_name=SideAds&showposts=2'); ?>
    				<?php $count = 0; ?>
    				<?php while ($my_query->have_posts()) : $my_query->the_post(); ?>
    				<?php $count++; ?>
    					<li id="post-<?php echo $count ?>" class="first">
    					<?php the_post_thumbnail( array(315,170) ); ?>
    					<div class="ad-li">
    					<div class="ad_title">
    					<h2><?php the_title(); ?></h2>
    					<div id="ad_text"><?php the_excerpt(); ?></div><div class="ad_link"><a href="<?php the_permalink();?>">Read More</a></div>
    
    				</div>
    
    					</li>
    				<?php endwhile; ?>
      					</ul>
    		</div>
    		<div style="clear:both;"></div>
    
    		<!-- Bottom Column -->
    		<div id="quote-other">
    		<div class="title-front">WEDDING FLORISTS IN THE COTSWOLDS</div>
    		<div class="text"><?php the_field('bottom_quote'); ?></div>
    		</div>
    
    			</div><!-- #content -->
    		</div><!-- #primary -->
    <?php get_footer(); ?>

    Note -I've moved the following code from the end of the page to before the category filters. So I suspect there's a conflict. Any idea how to resolve this?

    <div id="quote-other">
    		<div class="title-front">WEDDING FLORISTS IN THE COTSWOLDS</div>
    		<div class="text"><?php the_field('bottom_quote'); ?></div>
    		</div>
  4. velvet_grooves
    Member
    Posted 1 year ago #

    it is definitely - it's this code which is conflicting with the other code. any ideas?

    <?php $my_query = new WP_Query('category_name=Weddings&showposts=5'); ?>
    		<?php $count = 0; ?>
    		<?php while ($my_query->have_posts()) : $my_query->the_post(); ?>
    		<?php $count++; ?>
    
    		<ul id="meet_the_florists">
    		<li>
    		<?php the_post_thumbnail('thumbnail', array('class' => 'weddings_thumb')); ?>
    			<div style="float:left; top:0px; width:250px;">
    				<span class="weddings-title"><?php the_title(); ?></span>
    				<div style="clear:both;"></div>
    				<span class="hotel-name"><?php the_field('hotel_name'); ?>
    				<div style="clear:both;"></div>
    				<?php the_field('hotel_location'); ?></span>
    			</div>
    			<div style="top:0px; float:right;">
    			<p class="wedding-season"><?php the_field('wedding_season'); ?>&nbsp;Wedding</p>
    			</div>	
    
    			<div style="clear:both;"></div>
    			<span class="wedding-summary"><?php the_content(); ?></span>
    			<div style="clear:both;"></div>
    
    			<div style="float:left; width:50%;">
    			<span class="photographer-name">Photographer | <?php the_field('photographer_name'); ?>
    			<br><a href="http://<?php the_field('photographer_web_link'); ?>" target="_blank"><?php the_field('photographer_web_link'); ?></a></span>
    			</div>
    
    			<div style="float:right;">
    			<span class="photographer-name">Hair and Makeup | <?php the_field('hair_makeup_name'); ?>
    			<br><a href="http://<?php the_field('hair_makup_web_address'); ?>" target="_blank"><?php the_field('hair_makup_web_address'); ?></a></span>
    			</div>			
    
    		</li>
    		</ul>
    		<?php endwhile; ?>
  5. velvet_grooves
    Member
    Posted 1 year ago #

    Another thought - what "appears" on the page seems to differ depending on the value of the amount of posts shown from a category. For example:

    <?php $my_query = new WP_Query('category_name=Weddings&posts_per_page=10'); ?>

    If I change that from 10 to 2 - the bottom quote shows. If I change it to >2 it doesn't show. Yet the fields on the right - if I remove them it shows the bottom quote. If they're on the page, the quote dissapears.

    Anyone? ( :-) )

  6. yopraag
    Member
    Posted 1 year ago #

    Hi,

    Maybe you should try and send in smaller snippets of code.
    Or give an online example.

    Basically if you add a the_field('bottom_quote') function on your page it should echo out the current pages' "bottom_quote" field.

    If you're not in a WP loop you have to explicitly point to the post you want to get the field from of using an ID:

    <?php the_field( 'bottom_quote', $post->ID );

    Also note that $post should either be global or in a foreach loop.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic