WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Custom Fields
Add Image/File - Media Library Not Displaying Files: Fix (3 posts)

  1. JenCarpeDiem
    Member
    Posted 2 years ago #

    When I try to add an image or file to a field from the media library, I can't see my images. I can see how many files I've got -- it displays "Images (5)" at the top, as it should -- but it won't actually display anything below that. I noticed that a few people have posted about this problem with no real solution, so I thought I'd share how I fixed it myself.

    I played with the frame's URL and noticed that it works just fine if I remove "&type=image" or "&type=file". Marvellous! :D

    To get rid of this bit of the URL permanently, I edited js/input-actions.js to remove "&type=image" from lines 421 & 1486 and "&type=file" from line 365. It works perfectly now.

    http://wordpress.org/extend/plugins/advanced-custom-fields/

  2. waffl
    Member
    Posted 1 year ago #

    I can confirm this works for me as well.

    I'm using WordPress 3.4.2 and ACF 3.5.0

    Works, but is a super hackish way to have to edit a core file like that. I'll post this to the ACF support and hopefully Elliot can shed some light on it.

    edit: Posted a link on this ACF discussion - http://support.advancedcustomfields.com/discussion/comment/9378#Comment_9378

  3. elliotcondon
    Member
    Plugin Author

    Posted 1 year ago #

    Check out the "type" param issue in the FAQ - http://www.advancedcustomfields.com/docs/getting-started/faq/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.