WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
[resolved] Unsubscribed User Problem (21 posts)

  1. mystifier
    Member
    Posted 2 years ago #

    After updating to v1.5.7, non logged-in visitors can't open anything.

    I tried adding a _Visitor role and set the capabilities to the same as subscriber but it didn't fix it.

    I have had to quickly revert to v1.4

    http://wordpress.org/extend/plugins/advanced-access-manager/

  2. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Mystifier,
    What does you mean under non logged-in visitor can't open anything?
    If user is not logged in there is no sense to assign any capabilities. WordPress does not recognize them.
    _Visitor is for frontend only. And the only thing you can do is to set restrictions or exclude.

    Regards,
    Vasyl

  3. mystifier
    Member
    Posted 2 years ago #

    Hi Vasyl,

    Without changing anything else, after updating to v1.5.7 AAM, if a visitor (frontend) tries to open a post or category, they get the 'Unauthorized Action' screen.

    After reverting to v1.4 AAM without changing anything else, everything is fine again.

  4. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Mystifier,
    Thanks for info. Maybe there is so problems with settings transfer.
    I reorganized way of saving them in 1.5.7

    Appreciate.

  5. pixelbait
    Member
    Posted 2 years ago #

    I am getting the same error. All of the Category pages on my live site are displaying a white page with the words "Unauthorized Action" when I have the Advanced Access Manager Plugin activated.

    This issue occurs for all visitors to the site and it also seems to occur for all registered users except for the Admin.

    There is another post that identifies this issue as well.
    http://wordpress.org/support/topic/unauthorized-action-when-trying-to-browse-category?replies=3#post-2572368

    Is there a known fix for this? I am running 3.3.1

  6. Cyranoz
    Member
    Posted 2 years ago #

    As for myself, when a user has access to a post belonging to his group, everything works fine. If I click on a category, I get the message "Unauthorized action", even if there are posts in this category belonging to his group.

    After reverting to 1.5.6, everything was fine again, so there must be a bug or something in your latest version.

    Thanks for providing us with this great plugin anyway.

  7. pixelbait
    Member
    Posted 2 years ago #

    I am experiencing the same issue for all visitors/non members and for all roles except the admin. I am running 3.3.1.

    This is a great plug in and I would love to get a fix for this. Please keep us posted on the status.

  8. tradi
    Member
    Posted 2 years ago #

    I faced the same problem also.
    When activating Advance Access Manager visitors cannot access categories. They always receive "Unauthorized Action" error when trying to do so!

    Please let me know if you have a fix of this problem!

  9. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Looks like the problem is solved.
    Please go to advanced-access-manager/models/mvb_model_accesscontrol.php and replace the line 83 with:
    if (self::checkCategoryAccess($cat_obj->term_id)) {

    I'm sorry for this bug.
    It'll be implemented in next release in few days.

    Regards,
    Vasyl

  10. tradi
    Member
    Posted 2 years ago #

    yes.
    Your'r right.
    It has been solved with the new upgrade.
    Many thanks for your care.

  11. mystifier
    Member
    Posted 2 years ago #

    Seems okay so far. I will change it on the live site so should hear pretty soon if not.

    At last I can leave 1.4 behind :-)

    Thanks Vasyl

  12. Josh Fialkoff
    Member
    Posted 2 years ago #

    Hi,
    I wanted to check in and see whether this is resolved?
    I got this error today.
    Here's a screenshot:
    https://skitch.com/joshfialkoff/8kykw/wordpress-error
    Thanks for your help!
    -Josh

  13. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Josh,
    That looks like you restricted access to profile page in Menu Tab for current User or Role.

    Please check if that is true.
    Regards,
    Vasyl

  14. Josh Fialkoff
    Member
    Posted 2 years ago #

    Hi Vasyl,

    Thank you so much for your quick reply!

    I am having trouble with the Metaboxes & Widgets area. I get this error:

    >>To initialize list of metaboxes manually, copy and paste the URL to edit screen page into text field and click "Initiate URL". List of all new metaboxes will be added automatically.

    I don't see what the correct format is. I tried:
    http://www.domain.com/wp-admin/admin.php
    http://www.domain.com/wp-admin/widgets.php

    Thanks again,
    Josh

  15. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Josh,
    Nope these are not correct URLs.
    Just a quick lesson what is metabox for AAM:
    Metabox is something that u see when u are editing a post or page, or custom post type. It means that it is a box that u can drag & drop.
    So two URLs you presented does not refer to edit Post/Page or Custom Post Type page. That is why that does not make any effect.

    Regards,
    Vasyl

  16. Josh Fialkoff
    Member
    Posted 2 years ago #

    Thank you Vasyl,
    Would it be possible to add an example URL to the instructions so that people would know the correct way to format this?
    I am not sure what the URL to add here is.
    Thanks,
    Josh

  17. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Yea :) I knew that this is really weird feature and probably confused a lot of people. And thanks for idea. It's already on my todo list for next release.

    Regards,
    Vasyl

  18. Josh Fialkoff
    Member
    Posted 2 years ago #

    Great! Thanks for all of your help and for contributing to the WordPress community.

  19. latikas
    Member
    Posted 2 years ago #

    I am getting the same error. All of the pages on my live site are displaying a white page with the words "Unauthorized Action" when I have the Advanced Access Manager Plugin activated and Simplr User Registration Form activated. When user registered from the front site and after login user can not access the pages like profile.php and others and displaying this "Unauthorized Action".

  20. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    latikas,
    As I mentioned in other topic, check error log file and restore default settings for each role.

    Regards,
    Vasyl

  21. brownstone73
    Member
    Posted 1 year ago #

    Hi,

    I have been trying to get an answer on my question on how to edit "Unauthorized Action" page when users are not authorized to see a certain category/post.

    Anyone has any ideas?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic