WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
[resolved] "Plugins" Tab in Admin Panel cannot be disabled (3 posts)

  1. steckinsights
    Member
    Posted 2 years ago #

    I created a role called "Form Access" and attempted to prevent users with this role from accesses anything but my Gravity Forms panel. Everything else works, except that I am unable to restrict access to the "Plugins" tab/menu.

    I selected the user role and applied the settings to all users with that role, then in AWM Group (plugin tab) > Access Manager (sub-menu) > Main Menu (tab), I clicked "Whole branch" under the "Plugins" section and saved changes. This hasn't seemed to have any effect on my users with that role.

    Any thoughts?

    http://wordpress.org/extend/plugins/advanced-access-manager/

  2. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi steckinsights,
    Hm, I have just tried to do that on my test server and it works.
    Make sure that you have the latest AAM version. And try to deactivate other plugins. Maybe some plugin manually change the Admin Menu.

    Regards,
    Vasyl

  3. steckinsights
    Member
    Posted 2 years ago #

    Thanks Vasyl,

    What I ended up doing in order to solve the problem is that I deleted the user with the custom role, because I had the haunting suspicion that a setting had been changed in particular for that user, and although I had "reset" the settings, I was beginning to think that something in the database was not updating correctly.

    So after deleting that user, I re-created the user and re-assigned the custom role to that user. Then I re-applied the settings to the custom role (not the particular user) which seems to have fixed the issue.

    Thanks for checking in on me. All is well now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic