WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
Pages not shown (4 posts)

  1. mantish
    Member
    Posted 2 years ago #

    Hi,
    I just installed your plugin. It's great. Thank you.
    However I'm having an Issue: In the "posts and Pages" tab no pages are shown, I just see [empty] under pages. Posts are working fine.
    Does anyone knows what may be wrong?

    http://wordpress.org/extend/plugins/advanced-access-manager/

  2. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Mantish,
    How many pages do you have? WordPress has some interesting issue with pages. Sometimes first few it does not want to recognize. And I'm using native WordPress function to grab them. The only solution I had is just to create few more pages.
    If you have quit enough pages then, probably you have some error.
    Please check AAM error log in way it is described here - http://whimba.org/forum/viewtopic.php?f=6&t=11

    Regards,
    Vasyl

  3. mantish
    Member
    Posted 2 years ago #

    Hi Vasyl,
    you were right. I created a new page and that one is shown, however the other ones are still not showing. I got no errors in the log.

    --

    I checked your code and I think I fonud the problem. It's in the query that gets posts without category (mvb_model_ajax.php line 641). I think the error is produced because wp_term_relationships table is connected with wp_links and wp_posts, and there are some posts with the same id as some links. However I don't know how to fix it...

    --

    I deleted all links in my install and now the pages list works fine!! I think it could be a solution as long as you don't use links in your blog

  4. greenlinkweb
    Member
    Posted 1 year ago #

    I'm having the same problem?? So is the only fix to create a new page and copy and paste all info from the existing for it to show up in aam??

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic