WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
[resolved] "Fatal error" when I try to use this plugin (7 posts)

  1. galluzzino
    Member
    Posted 2 years ago #

    I love this plugin! I use wordpress as a CMS and I often need to clean the administration form all the menu intems and metaboxes that make it difficult for non teck people to use it. I used to use adminimize but it was quite limited. Thanks!!
    Unfrtunately when I use it I get both on the front-end and backend an the error "Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 309672224 bytes) in Unknown on line 0". I tried to increase my memory size in my wp-config.php but It still does it. The error disappear when I deactivate the plugin.

    any help?

    thanks again!

    http://wordpress.org/extend/plugins/advanced-access-manager/

  2. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Galluzino,
    Tell me how many pages, post and categories you have. And how many restrictions you specified.
    Regards,
    Vasyl

  3. galluzzino
    Member
    Posted 2 years ago #

    Hi Vasyl, congratulation fro the plugin! I have been looking for something like this.

    The site where I'm testing the plugin is under construction (maintenance mode) and so far has 38 Posts, 14 pages, 16 categories, 7 contributors and 6 editors. I took off all the restrictions. The restrictions one under capabilities are the default ones.
    When I try to get under the "meta boxes and widgets" the progress-bar gets only at a tenth. But if I refresh I get all the metaboxes in dashboard, posts and pages.
    I try to take of the maintenance mode plugin and disactivate some others without luck.

    thanks again.

    galluzzino

  4. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Galluzzino,
    This is very strange issue. I didn't get complains like that. How many plugins you have installed?
    Advanced Access Manager does not require a lot of memory space, more over there is no dangerous loops or incredible inheritances.
    Try to deactivate you current theme and all plugins and try it again.

    Regards,
    Vasyl

  5. galluzzino
    Member
    Posted 2 years ago #

    I tried to deactivate all the plugins (except for Advanced Access Manager), change theme to Twenty Eleven 1.2, the wordpress default one. Tried to optimize and repair the database,
    But no luck, the error message keeps one coming up.

  6. galluzzino
    Member
    Posted 2 years ago #

    It works!! My wp-config-php was set to catalan: define('WPLANG','ca');
    I created the ca.po end ca.po from the .pot file in the language directory and now it seems to be working fine.
    Thanks for the great plugin!!!

  7. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    I'm glad it works. And thanks for posts. It gave me some thoughts how to optimize some parts of Advanced Access Manager.
    Regards,
    Vasyl

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic