WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
[resolved] Fatal Error (16 posts)

  1. mystifier
    Member
    Posted 2 years ago #

    Updated to v1.5.6

    When a non-admin tries to Add or Edit a post, they get:

    Fatal error: Call to undefined method mvb_Model_UserConfig::issetMetabox() in ~/wp-content/plugins/advanced-access-manager/models/mvb_model_filtermetabox.php on line 86

    Is there anywhere to download v1.4.1? Since then, updating has caused major problems.

    http://wordpress.org/extend/plugins/advanced-access-manager/

  2. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    I've got it. Will be resolved today.

  3. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Go to mvb_model_filtermetabox and replace line 86 with
    f ($this->user_conf->hasMetabox($post->post_type . '-' . $metabox)) {

  4. mystifier
    Member
    Posted 2 years ago #

    Hi Vasyl,

    I just tried this on a test site and the initial problem is solved but I am now seeing:

    Fatal error: Uncaught exception 'Exception' with message 'Unauthorized Action' in ~\wp-content\plugins\advanced-access-manager\models\mvb_model_configpress.php on line 59

    when non-admin users try to open a plug-in section of the admin menu.

  5. kaotik
    Member
    Posted 2 years ago #

    Vasyl, didn't you test this before going live?

  6. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Please read this for more info - http://whimba.org/forum/viewforum.php?f=4

  7. kaotik
    Member
    Posted 2 years ago #

    Okay, but are you going to roll out a fixed version?

  8. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Maybe instead of Exception I'll redirect by default to home page or something.

  9. mystifier
    Member
    Posted 2 years ago #

    Are you saying that the site crash is because I don't have a newly required re-direct set-up somewhere after the update? If so, for sure it ought to default to something sensible if it doesn't exist.

    This is a really great plug-in Vasyl, but I feel it has lost its way a bit over the past few months.

    I have gone back to v1.4 (I have lost v1.4.1) to keep things running because it is the last stable version I have.

  10. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    It's your right to judge. Actually since 1.4 I'm doing much more complicated stuff with AAM, also it went through complete code refactoring.
    In fact this is free version, I do not spend required number of hours to perform testings. That is why I have users like you, how can point on bugs.
    I appreciate you for feedback and you help.
    Regards,
    Vasyl

  11. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi mystifier,
    Hope this topic will be helpful - http://whimba.org/support#viewtopic.php?f=6&t=11

    Regards,
    Vasyl

  12. mystifier
    Member
    Posted 2 years ago #

    Thanks Vasyl. We all love you really and you have given us one of the best wordpress plug-ins available.

  13. latikas
    Member
    Posted 2 years ago #

    I am getting the same error. All of the pages on my live site are displaying a white page with the words "Unauthorized Action" when I have the Advanced Access Manager Plugin activated and Simplr User Registration Form activated. When user registered from the front site and after login user can not access the pages like profile.php and others and displaying this "Unauthorized Action".

  14. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi latikas,
    What error log file tells you?
    Also try to click for each Role a Restore Button (http://whimba.org/forum/viewtopic.php?f=6&t=183)

    Regards,
    Vasyl

  15. latikas
    Member
    Posted 2 years ago #

    Hi Vasyl,

    Thanks for your replay,

    There is no error in log file, but when I registered one user from front side using Simplr User Registration Form and then login, user can not access the pages like profile.php and others. It's displaying this "Unauthorized Action". Also I have activated Access Manager Plugin to differentiate the users role. By default user role is Broker to adding a property using wp-property plugin.

    Regards,
    Latika

  16. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Latika,
    That sounds like your Broker Role is not configured properly. Also I have to check how Simple User Registration works.
    I let u know as soon as it possible.

    Regards,
    Vasyl

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic