WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
AAM not respecting FORCE_SSL_ADMIN (1 post)

  1. sickhippie
    Member
    Posted 1 year ago #

    A few weeks ago I fired up SSL on my site, and enforce it with this in wp-config.php:

    // Force SSL on wp-admin and login sessions
    define('FORCE_SSL_ADMIN', true);
    define('FORCE_SSL_LOGIN', true);

    The problem is, when I load the settings page, none of the included CSS and JS are served over SSL. In Chrome, this means they are not loaded at all (secure pages should never serve non-secure content). The upshot of this is the page is just one long list of options with every hidden message shown. It looks like the way those paths are defined will serve up a non-SSL page every time, no matter what. We even tried to force SSL on those directories at the server level, but to no avail since the links on the page are enqueued with a full path (including HTTP). Chrome will just ignore it since it's looking for HTTP on a secure page.

    Any ideas?

    http://wordpress.org/extend/plugins/advanced-access-manager/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic