WordPress.org

Ready to get started?Download WordPress

Forums

Adminimize
[resolved] problem with the latest version, after upgrade (1h ago) (55 posts)

  1. Ovidiu
    Member
    Posted 3 years ago #

    when it comes to hiding menus, I only see this: Can't load menu and submenu where I would formerly see the menus.

    I will revert back to the last version as that one worked for me.

    error log doesn't give me anything useful except maybe this:

    [Wed Mar 02 23:56:48 2011] [warn] [client 87.178.241.177] mod_fcgid: stderr: PHP Deprecated:  Function eregi() is deprecated in /var/www/clients/clientxx/webxx/web/wp-content/plugins/wp-phpmyadmin/wp-phpmyadmin.php on line 46, referer: http://www.jadeyoga.co.za/wp-admin/options-general.php?page=adminimize/adminimize.php

    http://wordpress.org/extend/plugins/adminimize/

  2. Ovidiu
    Member
    Posted 3 years ago #

    just realized downgrading doesn`t help me :-(

    not sure what else could have changed meanwhile...
    any idea?

    will give your 2.0 alpha version a try or should I rather try the development version?

  3. dancriel
    Member
    Posted 3 years ago #

    I am having the same problem in WP 3.1

  4. CallUp
    Member
    Posted 3 years ago #

    I am having the same problem too -- WordPress 3.1. It just started after having updated the Adminimize plug-in.

  5. CallUp
    Member
    Posted 3 years ago #

    I am having same problem (Can't load menu and submenu.). Started just after I updated Adminimize plug-in. Using WP 3.1

  6. micjamking
    Member
    Posted 3 years ago #

    bump

  7. wesleong
    Member
    Posted 3 years ago #

    Just upgraded and also am seeing the problem.

  8. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    What do you an version before?
    Can you save settings again for write menu-entries.
    I cant not see this problem in all installs and test-blogs :(

  9. Ovidiu
    Member
    Posted 3 years ago #

    I can save options, just not those, see here please: http://screencast.com/t/okxBdfKJnRn

    and here: http://screencast.com/t/Npojdq2d

    No idea what version I had but it was up-to-date so it must have been the one before this upgrade.

  10. daveshine (David Decker)
    Member
    Posted 3 years ago #

    I have the same problem with menu/submenu in Firefox 3.6.14 but in Google Chrome 10 beta it works perfectly! In Chrome in only drops down one admin bar item as I click on one of the drop downs in the global settings. But the plugin itself and the settings work for me. I think it's some tricky CSS or so???

    Thanx to Frank for the plugin and support!

    -Dave from Germany :)

  11. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    i hae tested in chrome 10, ff 3.6.13 and ff 3.6.14; but the settings was saved via $_post and this normaly not relevant from the browser. I thinnk is an error on the database, the menu and submenu is an entry in the settings and was write after install the plugin.
    Maybe you de- and activate the plugin or delete the settings via option on plugin-settings page.

  12. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    please can a people check this version: http://bueltge.de/files/beta/adminimize1.7.13a.zip

    Thanks for reply.

  13. daveshine (David Decker)
    Member
    Posted 3 years ago #

    Thanx for the reply! I've already done this what you suggested before my first post here. Activate/reactivate and also deleting all settings and reinstallation but it was like before in Firefox. I really don't know if it's an "browser issue" just tried with Chrome and worked there...

    I will now try your 1.7.13a version... thanx, dave :)

  14. daveshine (David Decker)
    Member
    Posted 3 years ago #

    So, I just tested with version 1.7.13a:
    deleted all settings, deactivated and reinstalled: now it worked! (also with Firefox).
    Don't know what it was...

    Thanx, dave :)

  15. dancriel
    Member
    Posted 3 years ago #

    I tried the 1.7.13a version. When I activate the plugin, the menu settings are present. As soon as I update any options, the menu area says "Can't load menu and submenu" again.

    Even if I don't make any changes at all to the Adminimize settings, still breaks after the Update button is clicked.

    I tried in both Firefox and Chrome - same problem.

    I deleted my settings for the old version before installing the new one. Any ideas Frank? Any info I can provide to help troubleshoot?

  16. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    @dancriel: can you export you options and send me, mail is on my blog

    Also you can check in the table _options for entry on field option_name with value mw_adminimize. See on this serialized data, you must finde the entry: mw_adminimize_default_menu and mw_adminimize_default_submenu

  17. dancriel
    Member
    Posted 3 years ago #

    @Frank: sent

  18. dancriel
    Member
    Posted 3 years ago #

    @Frank the latest version you sent me (1.7.14) works! The "Can't load menu and submenu" error is fixed. Thank you very much!!

  19. islandcastaway
    Member
    Posted 3 years ago #

    Same problems here ;(

    Tried adminimize1.7.13a.zip - didn't fix it.

    downgrading to 7.12 didn't work, had to restore database also

    I'm using 3.1 multisite

  20. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    please now use 1.7.14 and give me an feedback; i have add an fallback for reload menu-data

  21. islandcastaway
    Member
    Posted 3 years ago #

    on a dev site the options were blown out.

    when to the live site and exported the settings, re-imported to dev site and they were there.

    clicked on update settings with no real updates done and didn't get the error this time.

  22. daveshine (David Decker)
    Member
    Posted 3 years ago #

    Thanx Frank! Version 1.7.14 works on my projects!

  23. Ovidiu
    Member
    Posted 3 years ago #

    sorry for not following hte discussion too closely but I just tested the latest version: 1.7.14 and it works perfectly again.

    may I ask what the issue was, roughly, no details needed.

  24. funkimunky
    Member
    Posted 3 years ago #

    I am still having problems
    I have wordpress 3.1
    adminimize 1.7.14
    Capability Manager 1.3.2
    When I hide an admin panel for a custom role created in Capability Manager it does not affect a user of that role. Nothing is hidden.
    I am guessing that this is because Adminimize is not compatible with custom roles created in Capability Manager. I am going to test this out with the default roles in wordpress to see if Adminimize works with them.

  25. funkimunky
    Member
    Posted 3 years ago #

    I have tested this with custom roles created in Capability Manager 1.3.2 and this is what was causing my problems. I have reverted back to default roles and this has now fixed the issues i mentioned above.

  26. funkimunky
    Member
    Posted 3 years ago #

    sorry I've tested a further after creating the custom roles after I have installed adminimized 1.7.14 and it does indeed work with capability manager 1.3.2.
    It must have been messed up because the origional custom roles were created before I installed this new version.

  27. funkimunky
    Member
    Posted 3 years ago #

    I've figured out what was going on.
    I created new roles in capability manager by copying the default roles in wordpress. This was to simplify the names of roles for my users.
    To test adminimize I created a duplicate editor role using capability manager, calling it testeditor
    I now have two editor equivalent roles each with the same capabilities and levels 7, called Editor and testeditor.
    I created two users one for each role editor and test editor.
    I then deactiveated the same menus for both, this hid the menus for both.
    I then deleted the editor user and then deleted the editor role.
    Adminimize stops working for the testeditor roles user.
    If I recreate an Editor role and update the options in adminimize the hidden menus are hidden again for the testeditor role.

    It appears that without existing wordpress default roles adminimize stops working.

  28. Frank
    Member
    Plugin Author

    Posted 3 years ago #

    MAybe you can use this plugin http://wordpress.org/extend/plugins/members/ for create custom roles and change/addd objects on default roles and give me also an feedback.
    I have noc changed since verison 1.7.8 on the roles functions, only 1.7.14 has now a fallback for the users, she have problems to load menu data

  29. Ovidiu
    Member
    Posted 3 years ago #

    @funkimunk:
    this one is my favorite: http://wordpress.org/extend/plugins/user-role-editor/ might help you too.

  30. Tevya
    Member
    Posted 3 years ago #

    Frank, since I'm assuming you're subscribed to this thread, I just wanted to see if you were aware a lot of people are having issues with the latest versions (.13 & .14) of the plugin not working with WP 3.1?

    For me, it seems to work well for one or two user roles, but not for all. Some seem to completely ignore all settings, while at least one obeys almost all (not sure on one or two what they are).

    See these threads for more info:
    http://wordpress.org/support/topic/plugin-adminimize-not-working-at-all-for-me?replies=2
    http://wordpress.org/support/topic/plugin-adminimize-1714-not-working-in-305-or-31-for-admin-role-only?replies=6
    http://wordpress.org/support/topic/plugin-adminimize-1714-doesn-not-work-on-wp-31?replies=10
    http://wordpress.org/support/topic/plugin-adminimize-1715-not-working-in-wp-31?replies=2

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags