WordPress.org

Ready to get started?Download WordPress

Forums

Adminimize
1.7.22 broken with wordpress 3.3 for anyone else? (14 posts)

  1. T Klein
    Member
    Posted 2 years ago #

    Here is what happens, since the addition of the new admin bar on the backend dashboard pages the CSS is messed up. This is when I have it disabled for "editor".

    Here's what it looks like:

    http://i.imgur.com/bron1.jpg

    of course, it could be my own fault.

    http://wordpress.org/extend/plugins/adminimize/

  2. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    please check the backend theme on this user; maybe this user have an old entry to the theme; Adminimize dont support the backend themes form older versions of this plugin.
    Go to the user-settings and active the radio box on the theme blue or grey and update the user settings; please give me feedback.
    Thanks

  3. T Klein
    Member
    Posted 2 years ago #

    it doesn't work with either of the default themes. It seems to not be loading the CSS for the admin-bar. It works fine on the front-end of the site by removing it, but on the backend its all messed up.

  4. T Klein
    Member
    Posted 2 years ago #

    My Admin bar is styled wrong/has no style/won't format!

    You were probably using something like this to disable it:

    wp_deregister_script('admin-bar');
    wp_deregister_style('admin-bar');

    Remove that from your theme and you're GTG!

    If your plugin does anything like this, its a new feature that doesn't work in 3.3

  5. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    this one is only active, if you deactivate the Admin Bar via Adminimize; you can reset this option on the plugin.
    On my tests and many many installs on 3.3 works very fine.

  6. T Klein
    Member
    Posted 2 years ago #

    It works fine on the backend with it disabled? Can I see a screenshot of what its suppose to look like?

    I just tried it on a fresh install of wordpress and it was still messed up. :(

  7. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    please see here: http://www.diigo.com/item/image/1j30r/8n6s

    this was on a new install: http://www.diigo.com/item/image/1j30r/eah0

    but i have found a small bug with a changed "User-Info"; the Admin bar in 3.3 have an new css and my user-info is not on the right position.
    But the others works fine.

  8. T Klein
    Member
    Posted 2 years ago #

    You need to disable the admin bar.

    You will see how it messes up and how all the text that was on the admin-bar will get thrown to the left sidebar. I should of been more clear in my topic title. The plugin itself is not broke, just this one feature.

    http://i.imgur.com/bqY2Q.jpg

    Other then this one little thing, the plug-in works great and you did an awesome job. Its easy to use and covers everything I want and more.

  9. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    ahh :)
    ok, i will fix this.
    WP 3.3 has many changes on the admin bar and i have forgotten; to many options on this plugins.

  10. T Klein
    Member
    Posted 2 years ago #

    I appreciate you replying! Thanks for all the hard work! That's the only little thing I noticed when I upgraded to 3.3.

  11. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    please test this new version with changes for your problem: http://dl.dropbox.com/u/132701/adminimize.zip

  12. T Klein
    Member
    Posted 2 years ago #

    This works great!

    My only gripe is that since the admin-bar is disabled their is no link back to your website without typing in the URL manually. Unlike before where there was always a link to your homepage in the top left.

    That's not your fault though, just the way wordpress decided to design it.
    If it would be possible to pick which options you want disabled on the admin-bar some time in the future that would be awesome!

    It also removes the log-out button unfortunately. But you can re-enable that by enabling it on your user-info options.

  13. clickgnosis
    Member
    Posted 2 years ago #

    Hello
    The fix works great for me, thanx Frank, good work!

  14. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for feedback.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags