WordPress.org

Ready to get started?Download WordPress

Forums

Adminer
[resolved] Error message...possibly configuration related (10 posts)

  1. steve70638
    Member
    Posted 2 years ago #

    The install goes clean and when I go to tools and click on start adminer inside or in a new tab I get the following errors:

    Warning: include_once(/var/www/wpbeta/wp-load.php) [function.include-once]: failed to open stream: No such file or directory in /home/workshop/public_html/LHF-REVIEW.COM/wp-content/plugins/adminer/inc/adminer/loader.php on line 33

    Warning: include_once() [function.include]: Failed opening '/var/www/wpbeta/wp-load.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/workshop/public_html/LHF-REVIEW.COM/wp-content/plugins/adminer/inc/adminer/loader.php on line 33

    Fatal error: Call to undefined function current_user_can() in /home/workshop/public_html/LHF-REVIEW.COM/wp-content/plugins/adminer/inc/adminer/loader.php on line 43

    Thoughts?

    http://wordpress.org/extend/plugins/adminer/

  2. sem101
    Member
    Posted 2 years ago #

    Same problem

  3. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    Maybe you have set your plugin folder not inside the wp-install?
    I search for the wp-load.php; but if you define the folder on a other place of the webspace, then i cant find. I use this also; but i define the path. Please use the current trunk version: http://downloads.wordpress.org/plugin/adminer.zip

    edit the config.php inside the plugin-folder with the path to wp-load.php and then works fine.
    Thanks

  4. DaganLev
    Member
    Posted 2 years ago #

    Hey guys,
    we had the same problem which indicates that one of the includes is incorrect;

    PHP Fatal error: Call to undefined function current_user_can() in /home/<mysite>/public_html/wp-content/plugins/adminer/inc/adminer/loader.php on line 43, referer: http://<mysite>/wp-admin/tools.php?page=adminer/adminer.php

    which follows a warning:
    PHP Warning: include_once(): Failed opening '/var/www/wpbeta/wp-load.php' for inclusion (include_path='.:/usr/share/pear53:/usr/share/php') in /home/sites/<mysite>/public_html/wp-content/plugins/adminer/inc/adminer/loader.php on line 33, referer: http://<mysite>/wp-admin/tools.php?page=adminer/adminer.php

    The path "/var/www/wpbeta/wp-load.php" is incorrect. That seems to be set in the wp-content/plugins/adminer/config.php file on line 8:

    $wp_siteurl = '/var/www/wpbeta';

    after updating that setting to:

    $wp_siteurl = '/home/sites/<mysite>/public_html';

    It seems to work... (obviously <mysite> is the domain to be used)

    Can you please fix in the plugin core?

  5. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    If you have the default plugins folder inside wp-content; clear the value of the var in config.php to:

    $wp_siteurl = '';

    the plugin search automatcly for the files; its only an fallbac config for users, there install have an other custom path to the plugins.
    I will fix this value in the next upload.

  6. Rosie-L
    Member
    Posted 2 years ago #

    Hi.

    I just installed Adminer 1.2.1, and I'm getting the same Warnings and Fatal Error as the others have reported above. Here is my situation:

    Adminer's loader.php is at:
    /public_html/wp/wp-content/plugins/adminer/inc/adminer/loader.php

    Line 33 reads:
    include_once ( $wp_siteurl . '/wp-load.php' );

    The file wp-load.php is at:
    /public_html/wp/wp-load.php

    Exactly what are you saying I should alter to make Adminer work?

    Thanks for your assistance.

  7. Frank
    Member
    Plugin Author

    Posted 2 years ago #

    edit the config.php in the plugin-folder adminer, change from
    $wp_siteurl = 'C:/xampp/htdocs/wpbeta';
    to
    $wp_siteurl = ''; // example: '/var/www/wpbeta'

  8. Rosie-L
    Member
    Posted 2 years ago #

    Thanks.

    Setting $wp_siteurl = '' works.

  9. Will D. White
    Member
    Posted 1 year ago #

    Just grabbed a fresh copy of this plugin - using it with the latest version of WP and continue to get a 500 error trying to load it.

    I've opened the config.php file you mentioned, and $wp_siteurl variable is already set to '';

    I've tried to update it to the server location of wp-load.php manually - but no luck there either.

    My database isn't on localhost, do you think that could be causing a problem? Any idea what else could cause a 500 error?

    Thanks in advance.

  10. Frank
    Member
    Plugin Author

    Posted 1 year ago #

    the config is not important, if you use a single install of WordPress and default path. Delete the item in the config or uncomment it. The plugin search for the wp-load.php - this options is only for users, there have the plugins folder on a other domain or place.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags