WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Editor
[resolved] Problem on Multi-site - takes me to 404 when I save changes (4 posts)

  1. toddheitner
    Member
    Posted 1 year ago #

    I just installed the plugin on my WP MultiSite installation and network activated it.

    When I go to a site and try changing something and click to save changes, I'm taken to a 404 Page not found error.

    The URL looks like this:
    options-general.php?page=menu_editor&noheader=1

    Any idea what's wrong?

    http://wordpress.org/extend/plugins/admin-menu-editor/

  2. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    That URL looks fine. Normally, when you save a menu the plugin briefly goes to that URL (i.e. plugin page URL + "&noheader=1"), then redirects back to the menu editor.

    In this case, it sounds like there's a PHP error somewhere on that page. On some servers PHP errors and script timeouts can manifest as 404 errors. Check your server's PHP error log for recent messages - they should provide some clues as to what exactly is wrong.

    Also, if you have recently installed or upgraded any plugins, try temporarily deactivating them. The error might be caused by a plugin conflict.

  3. toddheitner
    Member
    Posted 1 year ago #

    Initially I did find some PHP errors, but I've gotten rid of those and I'm still having this problem. The error log isn't showing any errors now.

  4. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm, I'm not sure what else could cause a problem like this.

    Does the URL work if you just paste it into the address bar instead of being sent there by the plugin, or do you still get a 404 Not Found error?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.