WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Editor
higlight menu bug bug with custom_post_type (4 posts)

  1. Alinoee
    Member
    Posted 1 year ago #

    Hello,
    First, thank you for this very useful plugin.

    I found a bug with the hightlighting and custom post type.
    When I edit a custom post, it's never a good menu that is highlighted on the admin menu.
    This bug comes from file "menu-highlight-fix.js" with how to define if the link is the Current "Bestmatch" or not.
    In my case, the script detects that it is not the best link .... but it is!

    It really spoils the navgation a content type to the other and causes a lot of confusion for the user.
    Too bad...

    how to fix it?
    Thanks for your answer.

    http://wordpress.org/extend/plugins/admin-menu-editor/

  2. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    Could you provide some additional information about about the bug? Specifically:

    - When you're editing a custom post, what URL is in the address bar?
    - What's the URL of the menu that gets highlighted?
    - Have you moved the menu that corresponds to that post type somewhere else, or changed its URL in the editor (a screenshot would help)?

    If you prefer, you can respond via this contact form: http://w-shadow.com/contact/

    That form goes straight to my personal email and I usually check that more often than this forum.

  3. toto
    Member
    Posted 1 year ago #

    Hi, i found the same bug. here is the explanation.

    1. Install Woocommerce plugin

    2. Install the Admin Menu Editor

    3. Go to WooCommerce > Coupons and press Add Coupon
    Now the bug is presented: the menu highlight go to 'Posts > Add New' and its incorrect.

    So the coupons are custom post type - post_type=shop_coupon And the Admin Menu Editor broke the highlight of custom post types. If you disable the Admin Menu Editor Plugin the highlight is correct (Display the WooCommerce > Coupons - as active section in the menu).

    This is the bug???
    Its bad bug because if you use Capabilities plugin too and restrict access for some role don't write posts the bug try to go to 'Posts > Add New' but the access was restricted there, and user cant add coupons because of bug... :(

    How to fix it.
    Many thanks its great Admin Menu Editor Plugin ...

  4. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    Okay, I can reproduce the bug. It looks like the problem is that the plugin doesn't take into account the fact that "Posts -> Add New" should only be highlighted when adding a post, not any custom post type.

    Try this patch.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic