WordPress.org

Ready to get started?Download WordPress

Forums

Admin Menu Editor
[resolved] 1.1.7 + S2Member plugin = Broken (11 posts)

  1. chevymanusa
    Member
    Posted 1 year ago #

    Sorts everything properly as configured with plugin. However, when clicking on most items. The admin menu is showing S2member menu as selected and only show it's options.

    You seen a screen shot of the issue here:
    http://imgur.com/iQUWa
    and here:
    http://imgur.com/0DEx7

    Thanks in advance for the help!
    Regards,
    Chevyman

    http://wordpress.org/extend/plugins/admin-menu-editor/

  2. chevymanusa
    Member
    Posted 1 year ago #

    In the meantime while I wait for this to be addressed. I reverted the plugin back to 1.1.6 and it is working alright with S2member, no issues (yet).

  3. chevymanusa
    Member
    Posted 1 year ago #

    Same issue in 1.1.8.

  4. chevymanusa
    Member
    Posted 1 year ago #

    And here we ago with 1.1.9 having the same issue.
    Once the 1.1.9 (or 1.1.7 or 1.1.8) plugin is disabled. The above stated issue goes away. Plugin 1.1.6 still works with 3.4.1 and S2member with no issues. Please let me know if you need any help in addressing this issue.

    Regards,
    Chevyman

  5. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    This will be fixed in the next release. In the meantime, you can download a patched version here:
    http://w-shadow.com/files/admin-menu-editor.zip

    In case you're curious, the problem was caused by a new script introduced in 1.1.6 that got confused by a menu item added by s2Member that had the URL set to "#" (specifically, it's the horizontal divider element after "Other Itegrations").

    Since a link with href = "#" always points to the top of the current page, Admin Menu Editor assumed that it was the best match for the currently open admin page and selected the menu that contained this link.

  6. chevymanusa
    Member
    Posted 1 year ago #

    Ah okay, thanks for the response to the question/bug.
    It's developers like yourself that make wordpress. Thank you for diving into this issue and not just writing it off.
    Are you sure it started with 1.1.6? I am running 1.1.6 with no issues.
    Thanks again for the response, I look forward to the next update.

    Do you wish for me to mark this resolved now? Or should I wait until 1.2.0 comes out.

    Regards,
    Chevyman

  7. Janis Elsts
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm, let me check the logs... Yes, you're right - the new script was actually added in 1.1.7, not 1.1.6.

    You can mark it as resolved now. It will probably be a little while before 1.2.0 comes out. I don't want to annoy people with too-frequent updates, and the latest release was less than a week ago.

  8. chevymanusa
    Member
    Posted 1 year ago #

    Cool, Thanks again for your assistance and your service to the wordpress community!

  9. Icedizzy
    Member
    Posted 1 year ago #

    Hi!
    I do not know if its me or the plugin were the wishes ar not compatibele ;-)
    My wish:
    Creating an adminpanel menu item to point to a page inside an s2member protected part of the site.
    Creating the item works by giving its name the page and setting role to see the panel entry.

    The adminpanel entry are defined with url:

    http://example.com/?page_id=46

    But s2 ( i think ) adds a lot of crap on the url:

    http://example.com/?page_id=62&_s2member_seekingtype=page&_s2member_seekingpage=46&_s2member_seeking_uri=Lz9wYWdlX2lkPTQ2&_s2member_reqtype=level&_s2member_reqlevel=0&_s2member_restype=sys&s2member_seeking=page-46&s2member_level_req=0

    And if i just enter http://example.com/?page_id=46

    It just works ( already logged in of course but I was logged in from the beginning otherwise I would not have had access to the admin panel )

    Any ideas?

    page 62 are the membership optionpage i do not know why it should be involved at all because i have given http://example.com/?page_id=46 when creating the admin menu element.

  10. Icedizzy
    Member
    Posted 1 year ago #

    Versions:
    admin menu editor 1.1.9
    S2member 120703
    WP 3.4.1

  11. anthrotech
    Member
    Posted 1 year ago #

    Still broken. Menu items appear for Administrator. Users, but permission denied for All Users and Add Users. When I deactivate S2Member, Admin Menu Editor works perfectly. Please fix it.

    WP 3.4.2 (Multisite)
    S2Member 121023
    Admin Menu Editor Pro 1.50

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.