WordPress.org

Ready to get started?Download WordPress

Forums

Admin Customization
[resolved] Warning: getimagesize() - error on login page (4 posts)

  1. csbecker
    Member
    Posted 2 years ago #

    I’ve installed Admin Customization for WordPress. I installed and added a custom login graphic but I’m getting the following error:

    Warning: getimagesize() [function.getimagesize]: URL file-access is disabled in the server configuration in /homepages/40/d130529568/htdocs/ccsdance/wp-content/plugins/admin-customization/core.php on line 150

    Warning: getimagesize(http://ccsdance.beckerstudio.com/wp-content/themes/login_logo.png) [function.getimagesize]: failed to open stream: no suitable wrapper could be found in /homepages/40/d130529568/htdocs/ccsdance/wp-content/plugins/admin-customization/core.php on line 150

    I made sure that my image wasn't too large.
    Is there a way to resolve this?

    THanks! Chris

    http://wordpress.org/extend/plugins/admin-customization/

  2. csbecker
    Member
    Posted 2 years ago #

    You replied:

    You need to modify your php configuration.
    Edit your server php.ini and set "allow_url_fopen" to "On". You may need to talk to your hosting service to add that for you.

    I'm going to see if I can get that done.

    Thanks for the direction.

  3. csbecker
    Member
    Posted 2 years ago #

    OK - solution found. Thanks Alex.
    I have a shared hosting solution for this site.
    I created a new php.ini file and uploaded it to the site's root WordPress installation directory.

    The php.ini file simply included the following:
    allow_url_fopen = On

    Hopefully this will help someone.

  4. Aeroplankton Enthusiast
    Member
    Posted 2 years ago #

    Given many hosts will not allow "allow_url_fopen", here's a duct-tape** solution:

    Edit plugin file: admin-customization/core.php
    Edit function: ac_login_head_setup()
    Set*: $logo_path = 'wp-content/' . self::$options->login_logo;

    *By dropping the site_url() from the path getimagesize() should go local; avoiding the need for remote file manipulation.

    **May need to be re-applied with every update.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic