WordPress.org

Ready to get started?Download WordPress

Forums

Admin Customization
[resolved] dont work drop down menu (23 posts)

  1. Amin
    Member
    Posted 2 years ago #

    hi & thanks
    admin customization v2 work for me
    but when i active it dont work drop down wordpress menu(for Ex. dashboard ; write& ...)
    thanks

    http://wordpress.org/extend/plugins/admin-customization/

  2. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    Hi.

    I'm sorry but I'm not sure what you mean. The dashboard widgets list is updated only after you visit the Dashboard first. Does that help?

    Maybe you could use Google Translate to translate your message. http://translate.google.com/

  3. shady
    Member
    Posted 2 years ago #

    Hi,
    similar, i think, to the first post...
    Installed v2.0 on WP v3.2.1 and the admin menu will not display the submenu items in the dropdown when i click the little arrow beside the main menu item.
    Also, on the plugins page, if i click for the details of an item, it will open in a fresh window instead of the overlay that it should be.
    Maybe some script is not loading properly....?

  4. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    I've installed a clean WP v3.2.1 with Admin Customization 2.0 and I'm getting no such issues.

    Have you tried disabling all other plugins and then checking if the issues still occur? Also if you disable Admin Customization, the issues disappear?

    If you've done the things above, and you've determined that the plugin is at fault, please tell me if changing plugin settings creates those issues.

  5. shady
    Member
    Posted 2 years ago #

    I have disabled all plugins but Admin Customization 2.0 and getting the same issues. When i disable Admin Customization 2.0 the issues disappear.
    When the plugin is activated, there are various screen functions in the admin that are not functioning, such as the dropdown menus on the main admin menu, the expanding/collapsing actions for screen options, help menu, logout dropdown etc on all admin pages.
    I think the plugin is not finding a script file - on the settings page for the plugin it reads in the rightside column: "To update this list of widgets you must first visit the Dashboard." The link points to "http://example.com/wp-admin"( and will get a 'page not found' error)- whereas i am operating this WordPress installation in a sub-directory "example.com/wordpress and have this address as the site address and wordpress address until i have finalized the development. This addressing might be causing some problems...

  6. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    The wrong link issue will be fixed in the next release. That doesn't explain why WordPress UI javascript stuff don't work.

    The problem is that can't replicate what you are describing. Are you getting any JS errors? Check your Developer Tools/Firebug console for that.

    You could try comparing the source of the backend before activating the plugin and after.

  7. shady
    Member
    Posted 2 years ago #

    i couldn't detect any JS errors via Firebug, although i am no expert there.
    I did look at the backend source code , there are certainly some differences, but i'm not sure that i would spot an issue.
    If it would help at all, i can send or post txt docs of the backend source pages.

    thanks

  8. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    It would. Just archive both txts and upload them to dropbox or cloudapp.

    Thank you.

  9. shady
    Member
    Posted 2 years ago #

  10. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    Everything seems fine in the source.

    Activating WP_DEBUG might give more info. Anything there?

  11. shady
    Member
    Posted 2 years ago #

    No - activating the plugin and WP_DEBUG does not show anything new...
    I tried switching to default theme and same results.

  12. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    You could try selectively commenting js stuff in the plugin. See if that works.

    This is very strange. I don't seem to be able to replicate what you are telling me.

  13. saschapi
    Member
    Posted 2 years ago #

    I have the same issue! Sometimes it works and sometimes it doesn't! Maybe it is related to jQuery?

  14. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    What version of WP & jQuery are you using?

    I'm not sure what the cause is, and since I can't replicate it, I'm not able to fix it.

  15. honzza
    Member
    Posted 2 years ago #

    Hi, I had the same problem in Internet Explorer. I discovered it is caused by the console.log javascript function. The problem is in core.php file on the line 54. when you delete it, then it works ok. I think it is because console.log is not available in IE. Funny is, that after opening the javascript console it works :)

  16. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    Good catch about the log. I'll remove that in the next version.

    @saschapi, @shady, were you using IE?

  17. saschapi
    Member
    Posted 2 years ago #

    No, actually I was using Firefox. But maybe it is still related?

  18. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    Does removing the console.log from core.php fix the problem for you?

  19. saschapi
    Member
    Posted 2 years ago #

    Will have to check. I deinstalled the plugin cause I needed the site working for a demo. Next week I will have time to reinstall!

  20. saschapi
    Member
    Posted 2 years ago #

    I just checked it and it seems to fix the problem. For the moment all JS-Actions (like unfolding the options tab) are working.

    Hope this helps

    Sascha

  21. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    That sounds great.

    Will push 2.0.1 with the fix in the next few days.

    Thanks guys!

  22. shady
    Member
    Posted 2 years ago #

    I am using Firefox,
    when i delete console.log from core.php the WP JS stuff works correctly, many thanks for working this out

  23. Alex Ciobica
    Member
    Plugin Author

    Posted 2 years ago #

    2.0.1 is out. THis should not happen anymore.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic