WordPress.org

Ready to get started?Download WordPress

Forums

Share Buttons by AddToAny
[resolved] [Plugin: AddToAny: Share/Bookmark/Email Buttons] Add to Facebook Not working (15 posts)

  1. Courtney
    Member
    Posted 3 years ago #

    Dear Add to Any Gurus,

    I just installed your plugin, and it seems to be working beautifully, except for when adding to Facebook. When trying to post to FB, the permalink gets jumbled.

    What should be http://ihr.ucsc.edu/archives...
    ends up as http://http%3A%2F%2Fihr.ucsc.edu%2Farchi...

    Please advise on how best to track down the code that is adding an extra http:// to my link.

  2. garyrw
    Member
    Posted 3 years ago #

    I am having the same problem. In addition to that, the title always comes up as (No Title) instead of grabbing the post title.

  3. cheshmandaz
    Member
    Posted 3 years ago #

    Same problem here. Nobody from AddToAny or anybody else to help? Thanks

  4. outdooreyes
    Member
    Posted 3 years ago #

    You are correct. Facebook worked properly with the .8 release and the .9 release and the .10 release does not work for AddToAny. The big issue is that they released .9, I believe yesterday... which I updated to all my numerous blogs... and then released .10 today... which I though would fix the Facebook problem. As an entrepreneur (retired now), who has developed many years of innovative software, this type of update release is unacceptable for such a dominant company that many websites depend on. Simple code from Facebook does not depend on AddToAny integration and I don't believe that other than Twitter, the percentage of exposure with the many other options available from AddToAny makes that much of difference today.

    If AddToAny providers are slow or down, your website will not perform correctly and it probably will turn people away. I am considering just using the code directly from Facebook and Twitter and not have to deal with that possibility.

  5. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for the reports.

    This is actually a Facebook bug that affects mostly new posts & pages - basically any page that Facebook hasn't crawled and cached yet. We announced the issue with Facebook's bug on Twitter here. I'll report back when we hear more from Facebook.

  6. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    We just pushed out a workaround for Facebook's sharing bug where shared URLs are malformed just as cmahaney initially reported above.

    We're still waiting for Facebook to fix their "(No Title)" bug.

  7. Courtney
    Member
    Posted 3 years ago #

    Micropat, thanks so much for the updates.

  8. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for the initial report. :)

    AddToAny has switched over to using the AddToAny Facebook application that does not require end-user permissions for sharing. So far it's working wonderfully. It might even be better than before!

  9. jakechec
    Member
    Posted 3 years ago #

    I m having a problem regarding the icon which gets attached to the FB post. in the older version i could select what I wanted, now it automatically selects the Soundcloud icon! Please help!

  10. outdooreyes
    Member
    Posted 3 years ago #

    There is another problem (similar to the jakechec post above). It does not give you a choice of images and it selects only 1... the incorrect image.

  11. jakechec
    Member
    Posted 3 years ago #

    yessss that is what i was referring to :P

  12. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    Facebook reported that they had it fixed Thursday evening. After monitoring their endpoint for a while, we've reverted back to Facebook's native sharing mathod.

    Thumbnail selection is back!

  13. Fanaticweb
    Member
    Posted 3 years ago #

    Hi there, I noticed something lately also within the topic of the thumbnails, when users click the Like FB button, the thumbnail pulled is not even the one attached to the post.
    I'm using a theme with Custom posts, the thumbnail that was attached in the post was uploaded by the end user, meanwhile, when hitting the FB like button, the thumbnail is randomly pulled from the gallery of another active plugin (DataFeeder random Ads V3), is there a know conflict with this plugin or is this behavior related to the above discussion?
    For the record, this issue does not occur if we opt to Publish the post on FB, its just the Like button that is acting that way, had to disable it in the meantime.

  14. hoagvision
    Member
    Posted 3 years ago #

    I am also unable to choose any thumbnail used in respective post, acting very strange with what it chooses. Any help?

  15. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    Facebook Like doesn't accept values from AddToAny. Instead, Facebook scrapes your page for these details.

    You'll need to adjust your theme for thumbnail & description issues. Troubleshooting with Facebook's tool will give you a lot of insight into how Facebook is reading your pages:
    http://developers.facebook.com/tools/lint/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic