WordPress.org

Ready to get started?Download WordPress

Forums

Share Buttons by AddToAny
[Plugin: AddToAny: Share/Bookmark/Email Button] Issue caused by "uploads/addtoany/page.js" (5 posts)

  1. LJagermaster
    Member
    Posted 3 years ago #

    This seems to have happened on its own as I've not even looked at the plugin since I got it working properly (so probably a conflict with something else, I've just no idea what).

    When I double-click the exclamation mark in Avant! (running on IE's Trident engine) I receive the following error:

    Line: 1
    Char: 35734
    Code: 0
    Error: Invalid procedure call or argument
    URL: **removed**/uploads/addtoany/page.js

    On the homepage the URL links to the post and tries to open it in a new window when clicked (nothing happens on mouseover). But on the full post page it merely links to "http://www.addtoany.com/share_save" and again tries to open it in a new window when clicked (and once more, nothing happens on mouseover).

    I've no idea how the "addtoany/page.js" directory/file was created or why. I considered deleting it but wanted to check in case I end up mucking it up even more...any ideas?

    Thanks in advance,

    Lee C

    http://wordpress.org/extend/plugins/add-to-any/

  2. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Lee,

    Do you have "Cache AddToAny locally with daily cache updates" checkmarked in WP Settings > Share/Save Buttons > under Advanced Options?

    Try unchecking that option (which should be unchecked by default).

  3. LJagermaster
    Member
    Posted 3 years ago #

    I did have that checked - was for the sake of planning ahead as once it's finally launched I expect a lot of traffic - but unchecked it just now.

    However, I've just discovered it's an Internet Explorer issue (my primary browser is Avant! which runs on IE's engine) as clicking on the links on both the homepage and the post page in Orca (which uses FireFox's engine) and Opera cause the share/save box to appear. I'm still clueless as to how the "addtoany/page.js" dir/file appeared but I'm assuming it relates to the plugin appearing on pages (which I've disabled :-/ ).

    Anyway, I guess until the IE developers catch up I'll have to make it clear to all visitors/members that IE is not suitable, which is a shame as I personally prefer it (had issues with other plugins as well on IE's engine, this was just confirmation)...

    Oh, and the "Title" issue I mentioned in this thread, I later realised is more than likely caused by the Platinum SEO plugin (previously called the All In One SEO plugin). The title seems flawless in Opera, however in both IE & Firefox more often than not it displays the "span" code rather than the generated title. Is there a way to tighten the integration of both plugins?

    Thanks again,

    Lee C

  4. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    Both issues should be browser-agnostic. I'm not sure if the SEO plugin is doing something unique per browser, but the AddToAny plugin certainly doesn't do anything browser-specific except for some very minor IE styling that doesn't pertain to this issue. If you're getting different results in different browsers I'd guess you might be hitting the browser cache (or server cache) when testing different engines. When testing be sure to either disable your browser cache temporarily or to hard-reload each page you test. If you still see differences among browsers, it's likely that a caching plugin or perhaps that SEO plugin is using some sort of [poor] browser-sniffing method.

  5. LJagermaster
    Member
    Posted 3 years ago #

    To be honest I almost religiously delete my browsers cache before every page reload when testing out sites, and this one's no different. Of course there's always the online cache which I completely forgot about til now, when I've got the time I'll give it another look over after clearing both online and browser cache and see what happens.

    If you have at least 2 different installed yourself (ie. Internet Explorer & Firefox) then feel free to have a look yourself with them and let me know if you see any difference:

    http://sin.theweare.net

    Thanks again,

    Lee C

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic