WordPress.org

Ready to get started?Download WordPress

Forums

Share Buttons by AddToAny
[Plugin: AddToAny: Share/Bookmark/Email Button] 'a2a_config' is undefined error in browser (2 posts)

  1. Ken Soszka
    Member
    Posted 3 years ago #

    Hi, I am using the Arras theme with my own child theme, and I get the "Done, but with errors on page." notice in IE8 on my site, http://www.hoops411fast.com . I have not tried it in any other browser. These are the details of the error, I have read online that it may be related to the AddToAny Plugin:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6.6; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; Alexa Toolbar)
    Timestamp: Sat, 30 Oct 2010 01:31:23 UTC

    Message: 'a2a_config' is undefined
    Line: 229
    Char: 1
    Code: 0
    URI: http://www.hoops411fast.com/

    Message: 'a2a_config' is undefined
    Line: 250
    Char: 1
    Code: 0
    URI: http://www.hoops411fast.com/

    Message: 'a2a_config' is undefined
    Line: 271
    Char: 1
    Code: 0
    URI: http://www.hoops411fast.com/

    Anybody know why this occurs?

    Thanks!

  2. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    There have been a lot of problems with the Arras theme lately. Something in Arras is causing AddToAny to generate the required code too early in execution, thus the initial code isn't outputting. My guess is that the 'featured posts' section is what's causing the problem.

    You might try disabling 'Display at the bottom of post excerpts', or disabling automatic placement altogether and just hard-coding the placement into your theme.

    One immediate solution would be to disable 'Display at the bottom of posts on the front page' so that the button only appears on single posts/pages.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags