WordPress.org

Ready to get started?Download WordPress

Forums

Share Buttons by AddThis
[resolved] [Plugin: AddThis] Error when running admin behind SSL (5 posts)

  1. Bill Dennen
    Member
    Posted 3 years ago #

    Hi,

    There is a problem with this plugin enabled and this enabled in wp-config.php:

    define('FORCE_SSL_ADMIN', true);

    Specifically, in the admin, there is a mixed-content warning because of how addthis.css is loaded. It always loads it via http when it should load it via https.

    <link rel='stylesheet' id='addthis-css' href='http://somesite.come/wp-content/plugins/addthis/css/addthis.css?ver=3.0.3' type='text/css' media='all' />

    should be

    <link rel='stylesheet' id='addthis-css' href='https://somesite.come/wp-content/plugins/addthis/css/addthis.css?ver=3.0.3' type='text/css' media='all' />

    thanks.

  2. _mjk_
    AddThis Samurai
    Plugin Author

    Posted 3 years ago #

    Thanks for the report. This is fixed in version 1.6.8--please confirm it works for you!

    Best,
    Matt

  3. yuzz
    Member
    Posted 3 years ago #

    Hello Matt!
    I have version 2.0.6 of the AddThis plugin installed. With FORCE_SSL_ADMIN set to true, almost everything in the WordPress admin interface is loaded over https, except for the AddThis .css and .js files. Has something changed somewhere along the road? Or do I maybe need to change some settings somewhere?

  4. Aaron Jorbin
    Member
    Posted 3 years ago #

    Hi yuzz,

    Version 2.1.0 (just released this morning) should fix this. Sorry for the regression.

    -Aaron

  5. yuzz
    Member
    Posted 3 years ago #

    Hello Aaron,
    Thank you very much for the update! It works perfectly!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags