WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Plugin adds NOINDEX to pages that i want to index (14 posts)

  1. phattrance
    Member
    Posted 9 months ago #

    I just notised that the plugin is automatically adding the "noindex,follow" rule to all my subpages like:

    http://meme-lol.com/page/2/
    http://meme-lol.com/page/3/
    http://meme-lol.com/page/4/

    etc.

    even tho i have specifically chosen in the settings under the

    Noindex subpages of archives

    If you want to prevent /page/2/ and further of any archive to show up in the search results, enable this.

    To index those.

    SCREENSHOT: http://i.imgur.com/yVbTK1E.jpg

    does anyone know how i can fix this? Thank you

    http://wordpress.org/plugins/wordpress-seo/

  2. Sukhraj Grewal
    Member
    Posted 9 months ago #

    Untick that option. If you have ticked noindex subpages of archives. it will noindex

  3. phattrance
    Member
    Posted 9 months ago #

    thats the thing, the option isnt ticked. check the screenshot: http://i.imgur.com/v97JyW0.jpg

  4. Sukhraj Grewal
    Member
    Posted 9 months ago #

    is this only with subpages or the whole site . If the whole site make sure on wp-admin/options-reading.php Discourage search engines from indexing this site is unticked

  5. Sukhraj Grewal
    Member
    Posted 9 months ago #

    one more thing are you using http://wordpress.org/plugins/robots-meta/
    plugin. If using check its settings

  6. phattrance
    Member
    Posted 9 months ago #

    My current settings from the Reading settings in wordpress: http://i.imgur.com/Uvez1ku.jpg

    and no its not the whole site, im having only problem with the sub pages like page 1 page 2 page 3 etc.

    single posts etc has the index on it

  7. phattrance
    Member
    Posted 9 months ago #

    Nope not using any kind of seo plugin except the current one

  8. Sukhraj Grewal
    Member
    Posted 9 months ago #

    ok Try deactivating and reactivate the plugin see if this helps, Not Sure if this helps but no harm in trying

  9. phattrance
    Member
    Posted 9 months ago #

    yeah i tried that earlier this morning without any results. any ideas on what could cause this?

  10. Sukhraj Grewal
    Member
    Posted 9 months ago #

    ok i tried on localhost what it did if you tick that option it will add the noindex tag and after if you untick it it won't remove the tag that was added before, so now i am not sure how to delete that

  11. Sukhraj Grewal
    Member
    Posted 9 months ago #

    let me search and see what can i find and let you know

  12. phattrance
    Member
    Posted 9 months ago #

    update. i tried to reinstall the plugin without any results!

  13. sunamumaya
    Member
    Posted 9 months ago #

    It's not your fault, it's this rather poorly written plugin.

    Your issue can be solved like this (assumes you can edit PHP, and you have the latest version of the plugin):

    1. Open wp-content/plugins/wordpress-seo/frontent/class-frontend.php

    2. Go to line 582, it should look like this:

    ( is_home() && get_query_var( 'paged' ) > 1 )

    3. Select the entire line 582, and replace it with

    ( is_home() && get_query_var( 'paged' ) > 1 && ( isset( $this->options['noindex-subpages'] ) && $this->options['noindex-subpages'] ))

    EXACTLY as it I put it here.

    This will fix your problem. I basically added the check for the noindex-subpages option (the "No index subpages of archives" tick box in your screenshot). Without this check, the plugin treats your "home" archive outside the normal rule for archives controlled by that tickbox.

    IMO this is a very, very serious bug, as it literally hides your main post archive from search engines, behind your back, and this is done by a SEO optimization plugin...

    Good luck, let us know.

  14. quranforkids
    Member
    Posted 1 week ago #

    I have a same kind of problem but with my blog section http://quranforkids.org/blogs/ has sub pages like http://quranforkids.org/blogs/page/2/ now these pages produce duplicate content because they have part of the post that i am posting i want the sub pages to be noindex to them can any body help me with that i am using the yoast seo and in it the archive is no index but still the blog pase2 or 3 or 4 and showing when i check http://www.siteliner.com/

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.