WordPress.org

Ready to get started?Download WordPress

Forums

Force Strong Passwords
Plugin adds incorrect script in the admin (2 posts)

  1. hvdesign
    Member
    Posted 2 months ago #

    When activating this plugin I get a new script line loaded in this way:

    <script type='text/javascript' src='http://www.domain.coms?ver=1.0'></script>

    which never ends to load and make the admin panel very slow. No matter the domain or the extension always adds the final "s?ver=1.0"

    I've compared with other sites the and it's missing the complete path which should be something like:

    /wp-content/mu-plugins/force-strong-passwords/js-admin.min.js?ver=1.0

    Anyone else is getting this? How could I fix it?

    Thanks.

    https://wordpress.org/plugins/force-strong-passwords/

  2. Steve Taylor
    Member
    Plugin Author

    Posted 2 months ago #

    I'm not quite sure I understand this issue - in any case, I can't replicate it.

    The scripts that I see being loaded in admin with this plugin activated are like this in the header:

    <script type='text/javascript' src='http://domain.com/wp-content/plugins/force-strong-passwords/force-zxcvbn.min.js?ver=1.0'></script>
    <script type='text/javascript' src='http://domain.com/wp-content/plugins/force-strong-passwords/js-admin.min.js?ver=1.0'></script>

    They're both enqueued properly and work fine. I can't find any script reference that resembles the first <script> line you've included here.

    Also, you reference an installation with the plugin in mu-plugins, and I'm not sure this plugin would work properly in mu-plugins. If you're using it in that way, it would need a bit of adaptation (e.g. file paths because the main PHP file would need to go in the mu-plugins root) - and I would need a few more details to help.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.