WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Add to Any: Subscribe Button] Add to Any Subscribe - acting like a share/save button on hom (5 posts)

  1. simplifimation
    Member
    Posted 4 years ago #

    I am running the subscribe button on my blog http://www.simplifimation.com. On the home page the button appears to act as a share/save button (when it should be a subscribe button). On the other pages it appears to behave correctly - weird.

    I have tried everything I can think of but can't work this out - any ideas??

    M Hysted
    http://www.simplifimation.com

  2. micropat
    Member
    Posted 4 years ago #

    Just uncheck Display Share/Save button at the bottom of posts on the front page in Settings > Share/Save Buttons, and then Save Changes.

    Basically, this is a mix of an internal quirk with WordPress and the way your particular theme is setup to only display part of a post on the homepage.

  3. simplifimation
    Member
    Posted 4 years ago #

    Thanks - this fixed it. didn't think of looking in the share/save button options.

  4. artbycas
    Member
    Posted 4 years ago #

    Hrmmmm - Well, I tried the above solution, but it didn't fix my problem. I have a Static Page set for my home page, the Subscribe button in my sidebar (on every page of my site), and I have the Share button at the bottom of my posts.

    I already HAD the Display Share/Save button at the bottom of posts on the front page unchecked, so I had to also uncheck the Display Share/Save button at the bottom of pages option.

    The buttons now each work as expected across all pages of the site EXCEPT on the Single Post pages, (which are also the only pages on the site that display both at the same time), upon which the Subscribe button gets overwritten again by the settings in the Share button (they each display the same thing - the Share options).

    So basically, you can't use both at once on the same page.....?????

  5. micropat
    Member
    Posted 4 years ago #

    Hi artbycas, you can definitely use both buttons on the same page.

    Are you using the WordPress plugins for both buttons (here and here), or are you using the generic code from addtoany.com for one of the button types?

    If you're mixing the generic addtoany.com code with a plugin on the same page, that would be the cause of the mixup (reason being: special WordPress optimization for the plugin).

Topic Closed

This topic has been closed to new replies.

About this Topic