WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Add to Any: Share/Bookmark/Email Button] Two ShareSave buttons per page = 2nd button won't (6 posts)

  1. windows2000
    Member
    Posted 4 years ago #

    Just updated to .9.9.4.6 and did not fix this issue.

    I use pasted HTML to add a ShareSave at the top of certain posts.

    All my posts have a ShareSave at the bottom with the auto insert function.

    I want the menu to pop up only when they click the Share/Save button. I REALLY DON'T want them to leave my site via http://www.addtoany.com (which is what happens when this fails to popup the menu), because I can't track which service they shared with.

    Is there a bug or something that would cause this to break for the 2nd instance of the ShareSave per page?

  2. micropat
    Member
    Posted 4 years ago #

    Can you link us to an example of the problem?

    Also, when you say "pasted HTML", where are you getting that HTML from?

  3. windows2000
    Member
    Posted 4 years ago #

    Yes check out example:

    http://5frets.com/12/guitar-hero-world-tour-broken-strum-bar-repair/

    Notice at top of page, you can click ShaveSave and it pops up the menu. Beautiful.

    Now scroll 50% down (to the end of the Post, where Comments begin), and click that ShareSave. Instead of popping up, it takes you to addtoany.com.

    This HTML I paste at the top of a post, works great:

    <a class="a2a_dd" href="http://www.addtoany.com/share_save?linkname=Guitar%20Hero%20World%20Tour%20Broken%20Strum%20Bar%20Repair%20Guide&linkurl=http%3A%2F%2F5frets.com%2F12%2Fguitar-hero-world-tour-broken-strum-bar-repair%2F"><img src="http://5frets.com/wp-content/plugins/add-to-any/share_save_171_16.png" border="0" alt="Share/Bookmark" width="171" height="16" /></a>

    It's the AddtoAny inserted code that doesnt work properly.

    However check this page:

    http://5frets.com/264/guitar-hero-5-expert-drum-glitch-will-never-be-fixed/

    Notice it ONLY has 1 ShareSave - the auto-inserted one, and it works properly.

    Thus, the behavior happens when the 2nd ShareSave is added.

  4. micropat
    Member
    Posted 4 years ago #

    It appears that you didn't insert all the code generated from addtoany.com. It should look more like this (with the <script> tags):
    <a class="a2a_dd" href="http://www.addtoany.com/share_save?linkname=awfasd&linkurl=asdf"><img src="http://static.addtoany.com/buttons/share_save_171_16.png" width="171" height="16" border="0" alt="Share/Bookmark"/></a><script type="text/javascript">a2a_linkname="awfasd";a2a_linkurl="asdf";</script><script type="text/javascript" src="http://static.addtoany.com/menu/page.js"></script>

    Anyway, since you're already using the plugin, you should use the special plugin code to place the button properly in your theme.

    See "How can I move just the button to another area of my theme?".

  5. windows2000
    Member
    Posted 4 years ago #

    I appreciate your help! But, I think you've got it a bit mixed up...

    The plugin inserts the button always at the bottom of the page. The only buttons that malfunction are the ones at the bottom of the page - generated by the plugin.

    And the only time they malfunction is when I paste a 2nd button at the top of the post. But keep in mind that the pasted Top button always works the way I want.

    Finally, note that my goal on certain pages is to have a button on BOTH the Top and Bottom - an issue which your FAQ doesnt address anywhere.

    So to be crystal clear - is there a way to have a ShareSave button at both the top and bottom of a post, only on certain pages, and have them both pop up when clicked?

  6. micropat
    Member
    Posted 4 years ago #

    Ah, sorry for the confusion. I could have explained better that I'm aware you want two buttons on the same page; one at the top, one on the bottom.

    The bottom button is good to go, believe it or not. Explanation aside (unless you're interested), it's your top button code that needs fixing.

    To get the button at the top of the page to work, you need to remove your current code (that you generated from addtoany.com) and replace it with the code from this specific FAQ entry: "How can I move just the button to another area of my theme?".

    Yes, that FAQ entry needs to be reworded to 'How can I add just the button to another area of my theme.' The word move implies also removing the default bottom button, which is not a part of the directions. Will fix. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags