WordPress.org

Ready to get started?Download WordPress

Forums

Add New Default Avatar
[resolved] New update gives errors (14 posts)

  1. CBKat
    Member
    Posted 2 years ago #

    Was asked to update via the dashboard today, I did and now for every post on the dashboard where there is an avatar I get the following message:

    Missing argument 5 for kl_addnewdefaultavatar::insert_img_correctly() in

    I don't think this worked for me from the get-go, so I deleted it.

    http://wordpress.org/extend/plugins/add-new-default-avatar/

  2. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    My apologies for any inconvenience this has caused.

    I think I've found the error in my logic, though I haven't seen the exact error message you mentioned.

    Would you be willing to reinstall the plugin when the next bug-fix version is out (v1.2.1)?

  3. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    I've just released the 1.2.1 bug fix, should be available for download within about 15 minutes.

    Your assistance in confirming the bug fix would be greatly appreciated.

  4. troydthompson
    Member
    Posted 2 years ago #

    Hi Kailey,

    Love the plugin, but getting the same error as SOHKat.

    Updated to V1.2.1 and seeing this on the bottom of all pages (admin + live blog):

    Warning: Missing argument 5 for kl_addnewdefaultavatar::insert_img_correctly() in /.../domains/mydomainname/html/wp-content/plugins/add-new-default-avatar/kl_addnewdefaultavatar.php on line 59

    Any help would be greatly appreciated.

    Thanks!
    Troy

  5. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    I'm still unable to reproduce the error.

    Can you provide some more details about your intallation? Like version and theme.

  6. troydthompson
    Member
    Posted 2 years ago #

    Sure.

    WP Version 3.3.
    Theme: The Local 0.1 by Darren Hoyt & Ben Gillbanks (http://prothemedesign.com/)

    Same situation as the first commenter, plugin was running fine (been installed for months on the same set-up), just upgraded to 1.2.1 and the error popped up.

    Odd.

    - Troy

  7. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    I have an idea, but I need to see the theme to test it.

    Would you be willing to send me a copy, or at least the functions.php file? trepmal (at) gmail (dot) com

  8. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    Also, are you using any other plugins that could be doing things to the avatar?

  9. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    Alright, I've installed more than a dozen free themes to try and get the error - no luck.

    Then started overriding certain functions with some small plugins, and I think it worked!

    Are able to give this a try: http://cl.ly/CypD

    Replace /wp-content/plugins/add-new-default-avatar/kl_addnewdefaultavatar.php with the contents from http://cl.ly/CypD

    Thanks a ton for your patience!

  10. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    v1.2.2 is now available from the Other Versions page:

    http://wordpress.org/extend/plugins/add-new-default-avatar/download/

  11. troydthompson
    Member
    Posted 2 years ago #

    Hey Kailey,

    Thanks for the quick work, even on a holiday.

    Will test out the new update later today and let you know how it works.

    Thanks!
    Troy

  12. troydthompson
    Member
    Posted 2 years ago #

    Hey Kailey,

    Update v1.2.2 worked. No more errors.

    Thanks again for the help!

    Troy

  13. brad@exula.net
    Member
    Posted 2 years ago #

    Kailey,

    Great plugin!
    I'm using it to integrate with a custom cms and account management system my organization uses that just happens to have avatars already uploaded.

    I did a bit of hacking to append the user_login to the url so basically it ends up looking like http://avatarserver.blah.com?username=<user_login&gt;

    Maybe in future versions you could make more than just %size% be replaceable in the URL.

    Might make it a bit more useful for people in mine or a situation.

  14. Kailey (trepmal)
    Volunteer Mod & Reviewer
    Plugin Author

    Posted 2 years ago #

    @brad, thanks for the suggestion.

    In the future, when your post is unrelated the thread, please start a new topic. You can do so by using the form on this page: http://wordpress.org/support/plugin/add-new-default-avatar

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic