WordPress.org

Ready to get started?Download WordPress

Forums

Add Local Avatar
directory does not exist (6 posts)

  1. ikidunot
    Member
    Posted 3 years ago #

    i am using wordpress 3.0 with the latest plugin. the directory is left to /avatars but whenever i try and upload, i get an errors saying directory does not exist.

    http://wordpress.org/extend/plugins/add-local-avatar/

  2. kleinermann
    Member
    Posted 3 years ago #

    I have the same issue. Is there any solution for this problem?

  3. Kwelch
    Member
    Posted 3 years ago #

    same issue here.

  4. 8bitpig
    Member
    Posted 3 years ago #

    I had the same issue and have come up with a workaround.

    I first changed the path under Avatar Settings to be "/public_html/avatars" and this allowed me to upload the file. Having looked at the code I think it was allowed because the directory "/home/username/public_html/avatars" did exist.

    The avatar failed to display anything (not even the default avatar), presumably because it assumed the path to my avatar was http://mysite.com/public_html/avatars/myavatar.png

    The problem for me was that the function avatar_root() in avatars.php was returning /home/username but my site was found under /home/username/public_html. I'm not sure if this is a limitation/bug of the function itself or something to do with the strange setup of my web host.

    I changed the line:
    $root = avatar_root();
    to:
    $root = avatar_root() . "/public_html";

    I also changed back the path under Avatar Settings to "/avatars".

    PS This is a hacky workaround and is not recommended.

  5. Abner999
    Member
    Posted 3 years ago #

    Same issue here.

  6. selfmade64856
    Member
    Posted 3 years ago #

    same here. WP 3.0.4

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic