WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Add Local Avatar] Avatars not uploading (9 posts)

  1. zapata
    Member
    Posted 4 years ago #

    Since the last upgrade to 2.9 and the plugin, authors trying to upload their avatar fail to get the image uploaded and instead we get the broken image sign. I checked the permissions on the avatars folder and they have not changed and remain at 775. As admin even I tried uploading avatars for authors from their profile and same issue happens, though in the avatar admin screen the url path to the avatar shows up next to the author, just no image exists.

    http://wordpress.org/extend/plugins/add-local-avatar/

  2. zapata
    Member
    Posted 4 years ago #

    adding to above, I tried with 777 permissions on the avatars folder, but the author image still does not upload.

  3. zapata
    Member
    Posted 4 years ago #

    checking the use legacy method, seems to have resolved the issue.

  4. CrimsonLB42
    Member
    Posted 4 years ago #

    I'm having the same issue of images failing to upload and resulting in broken links. I have set the avatars folder permissions to 777 and checked the legacy method option, but neither have resolved this issue.

  5. sarahd
    Member
    Posted 3 years ago #

    Know this is a simple fix, but double check the Users > Avatars panel settings for the upload directory and what your upload folder should be relative to.

  6. pixelandgrain
    Member
    Posted 3 years ago #

    Its working fine in WP 3 as well.. using ver 8 ..I am using that.. I also had same issue like you all and I tried all things what mentioned here.. i even try to manually add path but no result

    but i was reading note below avatar upload field and i see there is written example like "/avatar" and I tired first like "home/myhostfolder/public_html/myrest path" but no result than I tried same as in note like "/avatar" and it works perfect than i check on root/avatar. and working fine now I breakdown the issue again I tired with "/publim_html/my path" no result than I remove public_html from path and tired only "/mypath" and it works absolutely fine.

    I dont know either I was funny or its like that only but now its working with above path..

  7. letmein
    Member
    Posted 3 years ago #

    Thanks, pixelandgrain. Your solution fixes the problem for me

  8. kleinermann
    Member
    Posted 3 years ago #

    It is still not working for me regardless of the path. I get the following error message:
    Upload error: Upload directory doesn't exist.

    The folder exists, and i have given it the 777 permission.

    Is there a solution for this problem?

    Regards,
    Stefan

  9. gypsie
    Member
    Posted 3 years ago #

    I am using version 3.0.1 and I got best results by using legacy checkbox (for v7.3 and lower) with 'avatars/' path. Reason this works better is a little function in avatars.php plugin called avatar_root() that figures better true path of your current root directory. This works well even if you are using wordpress in subdomains (I tested it). Of course you still have to create directory in your root wordpress folder called 'avatars' and set permissions on it to 777.

Topic Closed

This topic has been closed to new replies.

About this Topic