WordPress.org

Ready to get started?Download WordPress

Forums

Add Local Avatar
Another plugin has broken this one (2 posts)

  1. rlntls
    Member
    Posted 1 year ago #

    Hi there, I installed this plugin, set all the twitter u/ns and the plugin looked good. I then added the WP Biographia Plugin which did not behave as expected, so I uninstalled it. I reinstalled this plugin and although the twitter u/ns are still there, 'use avatars' and 'use twitter avatar' boxes are ticked as before, the plugin no longer works. I have tried clearing the u/n box, 'update'ing, and refilling the box, removing the plugin completely and reinstalling, to no avail. Anybody got any ideas?

    http://wordpress.org/extend/plugins/add-local-avatar/

  2. vicchi
    Member
    Posted 1 year ago #

    Cross posted from http://wordpress.org/support/topic/wp-biographia-broke-my-add-local-avatar-plugin?replies=3 ... looks like my WP Biographia and your Add Local Avatar plugin aren't playing well together. I've tried to duplicate the problem but can't seem to get Twitter avatars working for a user ... can you point out what I'm doing wrong here?

    Original post on the WP Biographia forum follows ...

    -Gary

    So I've just taken a look at this and I can't actually get the Add Local Avatar plugin to work with Twitter avatars. I've tried my account name, vicchi, I've tried the account name with the @ prefix, @vicchi, and I've tried the URL to my Twitter profile, http://twitter.com/vicchi. In all cases, the plugin's display of my Avatar Type remains firmly fixed on Global.

    As I'm testing out this on a local install and not on a publicly facing web server, I have WP_DEBUG enabled in my wp-config.php. I've noticed several things.

    In Add Local Avatar's admin screen, there's two deprecated WordPress API functions or function arguments being used.

    This may or may not be significant. It's normally just annoying if you have WP_DEBUG enabled.

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /Applications/MAMP/htdocs/live-vicchi.org/wp-includes/functions.php on line 2722
    
    Notice: get_usermeta is deprecated since version 3.0! Use get_user_meta() instead. in /Applications/MAMP/htdocs/live-vicchi.org/wp-includes/functions.php on line 2638
    
    Notice: get_usermeta is deprecated since version 3.0! Use get_user_meta() instead. in /Applications/MAMP/htdocs/live-vicchi.org/wp-includes/functions.php on line 2638

    What may be significant is that Add Local Avatar is calling the get_avatar filter with the incorrect number of arguments, which results in these message when displaying an Avatar ...

    Notice: Undefined offset: 0 in /Applications/MAMP/htdocs/live-vicchi.org/wp-content/plugins/add-local-avatar/avatars.php on line 725
    
    Notice: Undefined offset: 0 in /Applications/MAMP/htdocs/live-vicchi.org/wp-content/plugins/add-local-avatar/avatars.php on line 725
    
    Notice: get_user_by_email is deprecated since version 3.3! Use get_user_by('email') instead. in /Applications/MAMP/htdocs/live-vicchi.org/wp-includes/functions.php on line 2638
    
    Notice: get_usermeta is deprecated since version 3.0! Use get_user_meta() instead. in /Applications/MAMP/htdocs/live-vicchi.org/wp-includes/functions.php on line 2638
    
    Warning: Missing argument 5 for WP_Biographia::get_avatar() in /Applications/MAMP/htdocs/live-vicchi.org/wp-content/plugins/wp-biographia/wp-biographia.php on line 435

    If you look at /wp-includes/pluggable.php at line 1667 for WordPress v3.4.2 you can see that the get_avatar filter should be called with 5 arguments ...

    return apply_filters('get_avatar', $avatar, $id_or_email, $size, $default, $alt);

    Compare this with /wp-content/plugins/add-local-avatar/avatars.php at line 1412, which is calling the get_avatar filter with only 4 arguments, missing out the final $alt argument ...

    return apply_filters('get_avatar', $avatar, $id_or_email, $size, $default);

    Again, this may or may not be significant but until I can manage to get Add Local Avatar to work with Twitter avatars, it's going to make this very difficult to test and replicate your problem.

    I can see you've also posted about this in the Add Local Avatar support forum (http://wordpress.org/support/topic/plugin-add-local-avatar-another-plugin-has-broken-this-one?replies=1), so I'll cross post an edited version of this post so the plugin's author can (hopefully) see this and maybe chip in on how to get Twitter avatars working.

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.