WordPress.org

Ready to get started?Download WordPress

Forums

Add Link to Facebook
Working but small issue (6 posts)

  1. 256studio
    Member
    Posted 2 years ago #

    When I publish to facebook. I have an image at the top of the article with caption. It pulls the captions html code and I have it set to use the excerpt.
    ‎[caption id="attachment_43" align="aligncenter" width="600" caption="Model:Ashley Barber | Photog: 256Studio"][/caption] Ashley barber,Came into the studio via a facebook referral. I enjoyed shooting with her. Thanks Scot."Read more ..."
    Read more link doesn't work either!

    Example: http://www.facebook.com/twofivesixstudio

    256studio

    http://wordpress.org/extend/plugins/add-link-to-facebook/

  2. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    You can uncheck the option 'Do not execute shortcodes for texts' to fix your problem with the image captions, but be sure to check if it doesn't conflict with other plugins, because it sometimes does.

    The 'Read more ...' on Facebook is just text, because Facebook doesn't allow us to use links (or any other HTML) in the link status text.

  3. 256studio
    Member
    Posted 2 years ago #

    Thank you I will try that.
    256studio

  4. 256studio
    Member
    Posted 2 years ago #

    No it didn't fix the issue.
    I tried to post long url and short url and still shows the captions in the post
    http://bit.ly/tNhof8
    or
    http://256studio.com/gallery/ashley-barber/

  5. 256studio
    Member
    Posted 2 years ago #

    I tried it on another site and I have just to leave out the caption part of the image. but that where I give the model and Photog Created.

  6. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    Actually I am quite sure that this should work, since I am using this on my own website and to be very sure I just tested it successfully too. Please note that changing this option does not alter existing links (maybe obvious). You can also try to disable the option 'Do not execute filters for texts', but disable the other option and be even more careful to check if there are no conflict with other plugins (the whole reason these options are checked by default). Your problem could originate from a conflict with another plugin too.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic