WordPress.org

Ready to get started?Download WordPress

Forums

Add Link to Facebook
[resolved] Started getting session expired starting yesterday 4.0.2012 (8 posts)

  1. alanpae
    Member
    Posted 2 years ago #

    For every post I'm getting:

    Add Link to Facebook - <Post Title>: Get me: Error validating access token: Session has expired at unix time 1334976832. The current unix time is 1335040481. @ 2012-04-21T20:34:41+00:00

    Started Late yesterday and continues onto today.

    Any ideas - Happening on every post now - Checked on Facebook and the post was not transferred to Facebook.

    http://wordpress.org/extend/plugins/add-link-to-facebook/

  2. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    Did you already try to authorize the plugin again?
    (just press on the authorize button)

    Which plugin version are you using?

  3. alanpae
    Member
    Posted 2 years ago #

    So I'll need to do this after every WordPress upgrade? That fixed it by the way.

    thanks,
    alan

  4. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    This error has nothing to do with upgrades, but is caused by an expired access token. The plugin does refresh the access token after each link added to Facebook and access tokens are normally valid for 60 days. It could be your last link was added more than 60 days ago or that Facebook has revoke the access token for security reasons (whatever the reason).

  5. yatespw
    Member
    Posted 2 years ago #

    I'm getting this same error message. The cURL 47 error notes to update to the lastest version. Do you have installation notes to update or upgrade, I tried installing new over the existing version and it fails.

  6. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    If the WordPress updater doesn't work for you, you can follow the instructions of the development version.

  7. seansean11
    Member
    Posted 2 years ago #

    Hey, I just got this same message and I believe it started when I moved my wordpress install to a sub-folder. I am also trying to install the plug-in on another site, which ALSO is installed to a sub folder. I got an error message when I went to authorize the Add Link To Facebook Plugin saying that there was no index file (meaning it was searching in the wrong folder for a file).

    To explain...for security reasons, I install wordpress into a sub-folder with a random name. Then, I pull the index.php and .htaccess into the main folder. From there I only need to modify the index.php so that it runs correctly.

    I got this method from the Digging Into WordPress book, but am ready to ditch it as it has caused me countless problems with themes and plugins. So here's the question: Is it probable that this type of installation is causing the problem with the plugin??? And if so, is it possible to modify the plugin so that it will work???

    I'd appreciate any type of help!!

  8. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    This has nothing to do with the plugin. If your WordPress installation isn't okay, you will have trouble with themes and plugins as you discovered.

    Maybe this WordPress codex item can be of help.

    Another remark: please don't hijack discussions of other people. They get notified of your message, which isn't relevant to this discussion. Next time please start your own discussion.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic