WordPress.org

Ready to get started?Download WordPress

Forums

Add Link to Facebook
Script Error when active plugin (8 posts)

  1. wsorokes
    Member
    Posted 2 years ago #

    When I activate the Add Link To Facebook plugin, I get an Script Error message. IE asks if I want to stop running the script and it just locks up the page. Any suggestions?

    http://wordpress.org/extend/plugins/add-link-to-facebook/

  2. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    Add Link to Facebook does not use custom written JavaScript, but the scripts Facebook provides. Can you send me the debug information as explained in the last question of the FAQ, so I can see what options you have set to pin-point which script might be the problem? Can you also post the exact error message? If available the name of the script file and the line number.

  3. wsorokes
    Member
    Posted 2 years ago #

    The messege I get is: "Stop running this script? A script on this page is causing Internet Explorer to run slowly. If it continues to run, your computer might become unresponsive." Then it has buttons Yes and No. If I click No a couple times, it will load the facebook like link. But I have to do this everytime i refresh the page.

  4. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    Can post a link to the page with the problem here, so I can take a look.
    If you don't want to post it publicly, use this contact form to send it to me (please reference this comment thread, so I know what to look for).

  5. nnnvvv
    Member
    Posted 2 years ago #

    I've been getting this too on http://www.southsidesix.org.uk/ and have been forced to disable the plugin.

    The script which was blocking IE was in the all.js file from Facebook.

  6. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    I am sure Facebook is aware of this issue.
    Just be patient, it will be fixed, but it always takes some time.

  7. nnnvvv
    Member
    Posted 2 years ago #

    It's still occurring. I re-enabled the plugin updated to the latest and IE hung again with the same pop-up. I've disabled the plugin again. I've added the AddThis plugin which doesn't seem to have the same issues.

  8. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    I am curious why AddThis works and Add Link to Facebook doesn't. There is only one Facebook like button after all.

    Question: are you using multiple Facebook plugins at the same time (this could be an explanation).

    Do you have this same problem on both multiple and single pages?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic