WordPress.org

Ready to get started?Download WordPress

Forums

Add Link to Facebook
[resolved] No more - More (13 posts)

  1. alanpae
    Member
    Posted 2 years ago #

    Hi,

    This just started up recently. On older posts I get a more button if the post was to long.

    Example:

    I've updated my web pages on How to compile C code. Most of the updates revolve around Solaris 11 Release version as well as cmake. It looks like cmake will become more entrenched over time and I don't see it going away so I've added a web page on how to use it. It's a lot like configure and attempts to ease the...See More

    This just stopped so now it looks like:

    I've updated my web pages on How to compile C code. Most of the updates revolve around Solaris 11 Release version as well as cmake. It looks like cmake will become more entrenched

    and if you click anywhere it takes you back to the blog.

    Did I do something or did something change.

    How do I get "See More" back?

    http://wordpress.org/extend/plugins/add-link-to-facebook/

  2. ralphmark
    Member
    Posted 2 years ago #

    Please follow this link i think it can help you out.

    http://wordpress.org/support/topic/read-more-link-missing?replies=3

  3. alanpae
    Member
    Posted 2 years ago #

    Thanks but it only happens on the Facebook side after I added a Twitter plug-in. It looks like this plugin is grabbing the output of the Twitter plug-in and posting that instead of grabbing the original post and posting that instead. Clash of the plug-ins I guess you could call it.

    WP to Twitter is the other plugin.

    https://wordpress.org/extend/plugins/wp-to-twitter/

    alan

  4. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    Maybe question U34 of the FAQ can help you.

  5. alanpae
    Member
    Posted 2 years ago #

    Thanks Marcel. So I disabled about 10 plugins including the one for Twitter and it's still happening. What's worse is I can see in the debug window that it should be using the W wordpress logo as is selected in the settings menu but on facebook it's using a different image entirely.

    Not sure what to do so I'm sending you a link to the post as well as the debug info.

    If I had ftp access I'd roll back to 1.53 or 1.52 to see if it's a version issue.

    The Facebook page is at:

    https://www.facebook.com/pages/Sun-Countrys-Weblog/190548394384722

    thanks,
    alan

  6. alanpae
    Member
    Posted 2 years ago #

    Ok, I managed to drop back to 1.4.9 and it's still the same so Facebook apparently changed something between 5.2.12 and 5.3.12 and I have no clue what it was.

    I added the QR Code as a Facebook page picture and then removed it but it's still in the posts. Any idea where it's coming from. :-(

    And I re-enabled the Twitter plug-in since it made no difference.

    Thanks,
    alan

  7. alanpae
    Member
    Posted 2 years ago #

    On 5.2.12 these were posted via the Facebook app named "blog" which is the app that I created when I first installed this plugin.

    On 5.3.12 these are now being "shared" instead of being posted as blog.

    5.3.12 11:43am

    Sun Country's Weblog shared a link.

    I just can’t make it add up. « Sun Country's Weblog
    http://www.ilkda.com
    "Sun Country's Weblog"

    May 2

    6:11pm

    Sun Country's Weblog posted something via Blog.

    "Sun Country's Weblog"

    Does that help?

    Thanks,
    alan

  8. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    I added the QR Code as a Facebook page picture and then removed it but it's still in the posts. Any idea where it's coming from. :-(

    Facebook does cache things for a long time (up to a week).

    Back to the issue:

    On older posts I get a more button if the post was to long

    Do you mean 'more' on WordPress or Facebook?
    For Facebook this is controlled by the option 'Text trailer' on the plugin settings tab 'Appearance' and the option 'Maximum text length with trailer' on the plugin settings tab 'Admin'.

  9. alanpae
    Member
    Posted 2 years ago #

    Actually I think its caused by Facebook now using "Shared as a link" versus the old method of "Posted something via blog."

    More on Facebook.

    Text Trailer: See More ...
    Max Text Length with Trailer: 1024

    Still coming up short. I think the changes are on Facebooks end and not yours. Unless the app docs have been updated I don't think there's a fix.

    Everything going to Facebook is now posted as a shared link - with disastrous results.

    https://www.facebook.com/pages/Sun-Countrys-Weblog/190548394384722

    alan

  10. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    Did you try the suggestion of question U37 of the FAQ?

    Or to formulate it different, do you use the feed or links API?

  11. alanpae
    Member
    Posted 2 years ago #

    It was clicked so I unclicked it and tried again. Works fine. Made a few more tweaks and everything works better than the way it used to. I can't remember changing the setting but apparently I did. Will send you a donation soon.

    Thanks for the assist,
    alan

  12. alanpae
    Member
    Posted 2 years ago #

    Beverage Money sent via paypal. You won't be retiring anytime soon on that paltry sum. :-)

    thanks,
    alan

  13. Marcel Bokhorst
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you very much!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic