WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Ad Buttons] Got fatal error when upgrading plugin (3 posts)

  1. buddha trance
    Member
    Posted 4 years ago #

    I just tried to upgrade to the latest current version of the plugin, released today, 2.1.6, and got a fatal error on the site. Had to rename the plugins folder, reactivate one by one, etc.

    The only two plugins creating this today, are ad-buttons and now my-blog-log widget... Wondering why - it was working perfectly before.
    Using WP 2.8.6

    http://wordpress.org/extend/plugins/ad-buttons/

  2. buddha trance
    Member
    Posted 4 years ago #

    This is the error I get:

    Fatal error: Cannot redeclare adbuttons_widget() (previously declared in /path/to/wp-content/plugins/ad-buttons/adbuttons.php:400) in /path/to/wp-content/plugins/ad-buttons/adbuttons.php on line 400

    looking into possible plugin conflicts after the upgrade. I disabled all and got an error upon activation, but not a fatal one to the entire site...

  3. buddha trance
    Member
    Posted 4 years ago #

    OK, though I still get an internal error upon activation, the plugin gets activated and the fatal conflict is with bbPress Latest Discussions. Marking it as resolved, as the plugin works. If anyone has found a workaround for such conflict, please, let me know! If I find a fix, will post it here.

    Edit: The nature of the error of not being able to redeclare the adbuttons_widget threw me off track. Sorry. The issue is only with bbPress Latest Discussions 1.7, as other users are getting similar errors and reverting back to a previous version.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags