WordPress.org

Ready to get started?Download WordPress

Forums

plugin activation warning (6 posts)

  1. mbeusen
    Member
    Posted 3 years ago #

    Tried activating the plug-in but it all of a sudden came up with "Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/mbeusen/public_html/wp-includes/widgets.php on line 777"
    Unable to access wordpress or undo problem....

  2. Samuel B
    moderator
    Posted 3 years ago #

    ftp or use host's file manager to rename the plugin
    this will deactivate it and let you log in to test

  3. mcfunky
    Member
    Posted 3 years ago #

    How do you solve that problem after you've re-entered? I had the same thing happen over the weekend and I don't know how to resolve it -- exact same message, only with my website/file.

  4. mbeusen
    Member
    Posted 3 years ago #

    I contacted my webhost and they suggested I deactivate/uninstall the plugin. This seems to have resolved the issue.

  5. mcfunky
    Member
    Posted 3 years ago #

    Thanks, I did that already - the problem is the plug-in was working before the update of my theme. I am hoping to fix it somehow. Glad yours is fixed though.

  6. johnosmond
    Member
    Posted 3 years ago #

    You need to complete your constructor function with an id_base and a name.

    So if your running php 5.3 (or <) then:
    function __construct() {
    parent::__construct($id_base = 'xyz_', $name = 'My Simple Widget');
    }

    or if you are not using php 5.3 or < then use the name of your class.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags